• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Vista hang- and hang and hang

Hi all

A mate presented me with his Vista laptop, running home premium. It was stuck in the installing stage 3 of 3 loop.

Under no circumstances was I to kill vista and start again. He had lost the copies of some of the programs.

I used the recovery console to rename the pending.xml file.

The machine rebooted correctly.

I decided to run the windows update and it hung.

I forced a reboot and ran sfc, it reported that there are 3 errors that it can not resolve- this seems to be common!!!

I installed malware bytes and told it to run, after 10 mins it hung again...

I told avast to scan at start up, went to bed and woke up in the morning to find the laptop hanging on the frozen login page- I am assuming that avast found nothing as it is set to prompt for action by default.

I decided to try disk clean up and discovered that Vista falsely claims that the event logs are 99.1 gb!!!

I told it to delete virtually everything but again it hangs.

Whilst in hang mode ctrl-alt-del does nothing, otherwise it throws up an error message about "failure security option".

The only restore point is one that I created, so no help there.

Winver suggests that it is pre sp1, so i tried to install sp1 from the desktop but it hung.

Forced yet another reboot- into safe mode, gets as far as crcdisk.sys and hangs. I am guessing that safemode is unable to initiate disk check. Another forced reboot into normal mode starts the disk check (no bad sectors). I do a proper shut down and go back to safe mode so that I can install sp1. After 30 mins I get error code 80073712

It seems to be related to the pending xml file that had been renamed previously.

I decided to install Vista Ultimate into the other partition on the hdd in order to rename the dozens of pending xml files that I found in the winsxs folder.

Whoopy another f'ing hurdle. You cant just navigate to the old install of vista and move files- you need to take ownership first!!! This I did.

Rebooted and went back to the old Vista install, pensively tried to ctrl-alt-del and it worked!!! Tried the sp1 update again. Hurrah seemed to be working, it rebooted and did the installing 3 of three updates. Then it hung on the please do not turn your pc off.

After an hour I forced a reboot. Windows started happily, then flashed up a 0x800f082d error stating that sp1 had not installed.

I googled the code and found one english mention of it. The advice being to kill the machine and start again from scratch...

Ok I will go back to windows update and tell it to install the updates one by one, hangs at 32% of the ie7 update- ctrl-alt-del falls over again...

Time for another forced reboot, into sfae mode and that hangs at crcdisk.sys, another forced reboot me thinks.

Now with a regular boot I get a BSOD

stop: 0x00000024 (0x00190445, 0x84834228,0xc00000102,0x00000000)

Another forced reboot and the same again.

f8 at reboot and select the old vista and tell it use last known working config- this leads to the bsod again.

Back to f8 and select the o/s again and tell it to repair vista- this take me back to the initial multi boot screen!!!!

No option than to boot into the new vista and let it run the chk disk. Not sure why but wmm2clip.dll is frequently mentioned here so am probably going to delete it- what have I got to lose?

Hang on check disk has gone mental!!!!

Screen is scrolling with "inserting an index entry with id **** into index $SDH 0f file 9" SDH might be incorrect the last 2 digits keep changing.

Currently at index id 7900+, am getting bored....


My Computer

Ok so it stopped at id 7942 and the old vista now boots once more.

I guess that I should be grateful that the check disk on one o/s fixes the other o/s.

Am trying to install sp1 again (again).

My Computer

Have downloaded the windows readiness tool and it install seemlessly- so much so that nothing seems to have happened- oh well time to try sp1 again.

Nope no luck.

After a couple o hours looking I try KB937287 which makes no odds, next I try KB949939.

Microsoft Update Product Team Blog : Windows Vista SP1 Prerequisite KB937287

Seems to go some way to explaining the problem.

KB949939 just causes it to hang AGAIN

My Computer


Thanks Pacinitaly

I created the reg key that you mentioned but the machine hung shortly after when running the fujitsu updater. I guess i need to create the other keys to go with it, eg KillServices

I am starting to think that this might be a bios problem preventing SP1 installation, it seems that Vista checks the BIOS on some machines and then refuses to offer itself as an update. If this is true then it wirrying from a security point of view!!!!

My Computer


HappyGuru Lovin2Help
Vista Guru
I feel you,
I hate to reinstall ( 12hrs)...I keep cloning every 2-3 weeks

My Computer

System One

  • Manufacturer/Model
    centrino core 2 duo 2.2ghz T7500
    Hard Drives
    500GB WD
    Internet Speed
    fios 35MB not!!!!
Check your bios settings for Stop: 0x00000024. I found that on a Dell XPS M1330, the SATA setting had to be changed from ACHI to ATA in order to get the system to boot. After a successful boot (which included an automatic chkdsk), I could change it back to ACHI. I have also read that others had to try disabling devices in the bios to isolate the issue.

My Computer