Solved Vista not recognizing Logitech mouse. Just my luck.

So. When I first installed it today the mouse worked fine, I had logitech setpoint on there (Mouse is a logitech M100)

And after installing some updates, the mouse wouldn't work with vista. I highly doubt an update broke it, So I prefer responses not about that since they were security patches.

Regardless I kinda need the mouse to work since I sort of well lack a touchpad. (broke not drivers)

Please hurry with your responses.
 

My Computer

System One

  • Manufacturer/Model
    Sony Vaio Vgn-NR498e
    CPU
    Intel(R) Core(TM)2 Duo CPUT575 @ 2.00GHz (2 CPUs), ~2
    Motherboard
    Chipset: Intel GL960 Motherboard: Sony MBX-182
    Memory
    3GB DDR2
    Graphics Card(s)
    Mobile Intel(R) 965 Express Chipset Family
    Sound Card
    Speaker/HP (Realtek High Definition Audio)
    Monitor(s) Displays
    32bit Color 59Hz
    Screen Resolution
    12800x800
    Hard Drives
    TOSHIBA MK2546GSX ATA Device 250GB 5400RPM
    Case
    White
    Mouse
    Logitech
    Other Info
    The touchpad is broken. It doesn't have a battery, and the laptop is from like 2008 or 9.
Nevermind. I really don't care anymore.
 

My Computer

System One

  • Manufacturer/Model
    Sony Vaio Vgn-NR498e
    CPU
    Intel(R) Core(TM)2 Duo CPUT575 @ 2.00GHz (2 CPUs), ~2
    Motherboard
    Chipset: Intel GL960 Motherboard: Sony MBX-182
    Memory
    3GB DDR2
    Graphics Card(s)
    Mobile Intel(R) 965 Express Chipset Family
    Sound Card
    Speaker/HP (Realtek High Definition Audio)
    Monitor(s) Displays
    32bit Color 59Hz
    Screen Resolution
    12800x800
    Hard Drives
    TOSHIBA MK2546GSX ATA Device 250GB 5400RPM
    Case
    White
    Mouse
    Logitech
    Other Info
    The touchpad is broken. It doesn't have a battery, and the laptop is from like 2008 or 9.
Top