• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Vista won't boot after using GParted

#1
I just got a new HDD so I decided to move a small Ubuntu partition off my main drive to the new drive, and resize the Vista Home Premium 32 bit partition on the main drive to fill the drive.

I did this using GParted and it all went smoothly, then I tried to boot Vista and I got this error:
http://www.betaarchive.co.uk/imageupload/1259507339.th.154517.jpg

I have the install DVD that came with the PC, so I booted from it and tried using startup repair and all of the commands here:
How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows
But none of them worked, I still get the same error.

Strangely, 3 times I have gone in to the boot menu (F12 at startup) and booted from the install DVD, Vista has booted instead, and I have not got the winload.exe error. It works normally, just as before the resize, I can take the install DVD out, and the size of the Vista partition is correct.
But when I try to boot from Vista again I still get the winload.exe error.

Thanks in advance for any help.
Phil
 

My Computer