• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

WD My Book stops being recognized

TEDIUM

New Member
Messages
2
#1
I just bought a WD My Book Home 1tb about 3 months ago, and I recently started having this peculiar issue with it. I can't "safely remove" as it says a program is using it (I have no idea what) and if I just unplug it, it isn't recognized under My Computer when I plug it back in. I tried using the eSATA connection on it, and I'm assuming it went to sleep or something and isn't accessible. I tried using USB again, on two different ports, and as per something someone said on another site, tried plugging into different outlets, all to no avail. It is listed under device manager as "working" but I can't access it. The only solution I have found is to reboot my computer, but that is quickly growing very annoying. If I plug into my friend's Vista PC (32bit I think) however, it works fine. Can anybody help me out with this?
 

My Computer

richc46

Staff member
Vista Guru
Gold Member
Messages
20,105
Location
Fairfield County, CT
#2
When you have the problem try bringing up the task manager. alt+cntrl+delete and see whats running. Stop each process, one at a time, and see what is stopping the removal.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

patio

Vista Pro
Gold Member
Messages
403
#3
Did you use the MyBook software with this drive ? ?
It's known to have issues...
 

My Computer

System One

  • CPU
    Intel Q6600
    Motherboard
    ASUS P5K MBoard.
    Memory
    4G OCZ PC2 8500 Platinum
    Graphics Card(s)
    EVGA 8800GTS Vid Card
    Hard Drives
    500G Seagate SATA
    200G Seagate SATA
    100G WD Caviar SATA
    80G WD Caviar IDE
    PSU
    OCZ Elite 800W PSU
    Case
    RaidMax Smilodon Case
    Other Info
    Lite-On dual layer DVD burner X 2
    Dos 6.2;Win2K;XP; &
    Vista Ultimate 64Bit.

TEDIUM

New Member
Messages
2
#5
Did you use the MyBook software with this drive ? ?
It's known to have issues...
When I got the drive, it was stupidly formatted in FAT32 some reason, so I reformatted to NTFS right away, and it worked fine for a while, it's just the past week or two it's done this.
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)