Weird MS Flight Sim Deluxe X problem

TomW

New Member
Recently, I bought Flight Simulator Deluxe 10 and installed it. Then Service Pack 1. Then SP2, which said it came with Direct X 10. It said not to install it if I'd installed the Expansion Pack, and I hadn't at that point. I finally bought it over the web at the MS Flight Sim site and during install, it said I had to remove SP 2. No big deal... I'd kinda expected it.

Anyway, Expansion Pack also says it comes with 'introduction to Direct X 10' and having a brand new eVGA GeForce GTX 285, I was excited to see the difference... as soon as I tired opening Flight Sim after all was said and done, I got error messages saying I needed to install Direct X... 9. So I installed 9.c again and everything workd-except Direct X 10?

Anyone have a clue why Microsoft did this?

Thank you.
 

Everlong

To xor or not to xor
Vista Guru
I didn't have that problem. I installed FSX main game, then the Acceleration expansion straight after as it comes with SP 1 and 2, and DX10 worked fine.

Have you tried just doing this and missing out SP1?
 
Top