Windows could not search for new updates - Code 80070424

blue sabre

New Member
This one has been puzzling me for a while, have removed security software so it isn't being blocked.

Also, when trying to install SP2 Standalone (though this may resolve the issue) I get the error: ERROR_SERVICE_DOES_NOT_EXIST.

I'm assuming the two are linked - anyone have any ideas?
 

My Computer

Flavius

Expelled
Check you have these services and correct set:

Windows Update -start AUTO
Background Inteligent Transfer Service -start DELAYED-AUTO
Cryptographic Service -start AUTO
Windows Modules Installer - start MANUAL

EDIT

I suspect you don't have Windows Module Installer -if yes you have to extract form your Vista DVD file TrustedInstaller.exe,place this file in C:\Windows\Servicing ,import special fix to registry from SYSTEM account attached in this thread & details here how to do that:http://www.vistax64.com/vista-general/218999-windows-modules-installer-missing.html
+restart next navigate to service Windows Module Installer (now this service should available) and run it manually

More details about this error we discussed in this thread:http://www.vistax64.com/windows-updates/197069-windows-module-installer-service-gone.html
 
Last edited:

My Computer

blue sabre

New Member
Check you have these services and correct set:

Windows Update -start AUTO
Background Inteligent Transfer Service -start DELAYED-AUTO
Cryptographic Service -start AUTO
Windows Modules Installer - start MANUAL

EDIT

I suspect you don't have Windows Module Installer -if yes you have to extract form your Vista DVD file TrustedInstaller.exe,place this file in C:\Windows\Servicing ,import special fix to registry from SYSTEM account attached in this thread & details here how to do that:http://www.vistax64.com/vista-general/218999-windows-modules-installer-missing.html
+restart next navigate to service Windows Module Installer (now this service should available) and run it manually

More details about this error we discussed in this thread:http://www.vistax64.com/windows-updates/197069-windows-module-installer-service-gone.html


Well doing that has changed my error code, I get 80070002 now!! Followed the microsoft help and support steps for his and still persisting.
 

My Computer

Top