• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Installer problems

jacton

New Member
Messages
5
#1
I am running Vista Home Premium 32bit and have recently encountered a problem when trying to install/uninstall some programs, I receive the following error message:-

''The Windows Installer service could not be accessed. This can occur if the windows installer has not been correctly installed. Contact your support personnel for assistance''

I have tried everything on the Microsoft site and I cannot even install the windows installer cleanup utility I get the error message in a box titled

'Windows Script Host' in a blue titled box then underneath
Script: C:\Users\TONYL~1\AppData\local\Temp\IXP000.Tmp\Start MSi.vbs
Line: 17
Char: 1
Error: Permission Denied
Code: 800A0046
Source: Microsoft VBScript runtime error

I have also tried sfc / scannow and it comes back with:-


'Windows Resource Protection did not find any intergrity violations'

I have tried contacting Microsoft but cannot get an answer, does anybody know what is wrong and how to correct the problem. I have tried running reg-cleaners and system restores back to the beginning of the month but the problem persists.
 

My Computer

MDOC

Veteran
Member
Messages
111
#2
You need to run the setup program for the windows installer cleanup utility as an administrator. Right-click on that file and click "Run as administrator" in the menu. That'll take care of the 800A0046 error code.
 
Last edited:

My Computer

MDOC

Veteran
Member
Messages
111
#4
Simply right-click on the setup file (I think that's msicuu2.exe or something like it), either in Windows Explorer window, or you can right-click on programs listed in the Start menu or an icon on the desktop.

A menu pops up and the second or third item down is "Run as administrator". Click on that. Then the UAC pops up, click "continue". And the setup will run.

If the UAC prompts you for a password and you don't know it, you're not using an administrator account in Vista.
 

My Computer

jacton

New Member
Messages
5
#5
Okay tried that and I now get the windows installer box with the original error message:-
''The Windows Installer service could not be accessed. This can occur if the windows installer has not been correctly installed. Contact your support personnel for assistance''

Back where I started. I am beginning to think the only way to sort out the problem is to wipe my hard drive and reinstall windows, but don't really want to have to do this.
 

My Computer

MDOC

Veteran
Member
Messages
111
#6
No, that's unnecessary. What happened when you ran the cleanup utility? Did you run it successfully? Did you download the latest cleanup utility? The latest is at Description of the Windows Installer CleanUp Utility

If it ran and it didn't seem to have rectified your issue, it simply means the problem is somewhere else. Your error code did get resolved. Right?

Try this:

Start the Windows Installer service
  1. Click Start, type Services.msc and press ENTER
  2. Double-click Windows Installer
  3. Set the Startup type of Windows Installer to Manual
  4. Click Start to start the service. Note down the error message if any.
  5. Click OK.
Windows Installer Registry Fix If the above steps do not help or if the Windows Installer service is not listed in the Services applet, follow these steps:
  1. Download msiserver.zip and save it to Desktop. This can be downloaded from here: http://www.winhelponline.com/blog/wp-content/uploads/msiserver.zip
  2. Unzip the file and extract msiserver.reg to the Desktop.
  3. Right-click msiserver.reg and choose Merge.
  4. Click Yes when asked for confirmation.
  5. Restart Windows.
 
Last edited:

My Computer

jacton

New Member
Messages
5
#7
Okay tried the windows installer registry fix, then tried to download the utility window installer and I am once again back where I started with the error message
'Windows Script Host' in a blue titled box then underneath
Script: C:\Users\TONYL~1\AppData\local\Temp\IXP000.Tmp\Start MSi.vbs
Line: 17
Char: 1
Error: Permission Denied
Code: 800A0046
Source: Microsoft VBScript runtime error
I have treid to unitstall a program I have been trying since all this started and get the error message
''The Windows Installer service could not be accessed. This can occur if the windows installer has not been correctly installed. Contact your support personnel for assistance''

Really nothing seems to clear the problem
 

My Computer

MDOC

Veteran
Member
Messages
111
#8
Okay tried the windows installer registry fix, then tried to download the utility window installer and I am once again back where I started with the error message
'Windows Script Host' in a blue titled box then underneath
Script: C:\Users\TONYL~1\AppData\local\Temp\IXP000.Tmp\Start MSi.vbs
Line: 17
Char: 1
Error: Permission Denied
Code: 800A0046
Source: Microsoft VBScript runtime error
I have treid to unitstall a program I have been trying since all this started and get the error message
''The Windows Installer service could not be accessed. This can occur if the windows installer has not been correctly installed. Contact your support personnel for assistance''

Really nothing seems to clear the problem
Did you forget to "run as administrator"?
 

My Computer

jacton

New Member
Messages
5
#9
It does not appear to allow me to run it as an administrator. When I downloaded the msiserver it asks to run or save I saved but when trying to unzip it does not giver me the option to run as administrator. when I click on this link http://www.winhelponline.com/blog/wp.../msiserver.zip it asks whether to open or save, I save to a file under downloads then new folder, but it will not allow me to unzip it as an administrator, I have tried right click on the file but there is no option to run as administrator. When I unzip the file it goes through the process of allow it to be added to the registry but when trying the windows install or uninstall I still get the error messages

I also tried the first option to start the windows installer service but get the error message when I tried to start the service

The windows installer service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

It seems I need to take my PC to an expert to have this registry problem repaired, as I am now past my actual computer skills to do more, but thanks for your help
 

My Computer

MDOC

Veteran
Member
Messages
111
#10
You don't need to unzip the file as an administrator. Just double-click the file to start the unzip process. After you have unzipped it, then run as administrator the file that was just unzipped.

I guess getting someone else to do this would be better. Yiou need somebody to show you how to do it.
 

My Computer

Messages
2
#11
I can totally relate. I spent two whole days on my (NEW) PC trying to figure out how to correct the same problem... "windows installer could not be accessed...error code 643) !! :sa: It can also come up with different error codes. anyhow, to cut to the chase, I ran accross this solution somewhere online in a forum on Windows and IT WORKED!!!! :cool:Try it. I don't know exactly how this guy :geek: figured this out but it definitely fixes the problem. From all the replies he was getting, it worked for a bunch of people having the same problem!

1) At Start type: regedit
Lft Click on: HKEY_LOCAL_MACHINE
Lft Click on: SYSTEM
Lft Click on: Services
Lft Click on: MSIServer

Rt Click on: WOW64, select Modify and change
value data from 1 to 0 (zero)

2) At Start type: run
Type: services.msc
Go to Windows Installer and stop and start the program.

3) Reboot your computer.

Now go and try and do an install. In my case the steps above took all of 3 minutes and i went to the application .exe file I was trying to install and it installed perfectly, not skipping a beat...everything since then has installed perfectly!
I'm curious to know if this works for you. Please let me know OK. Margie :) mp.baltierra@comcast.net
 

My Computer

System One

  • Manufacturer/Model
    HP Pavillion Model p6115y
    CPU
    AMD Athlon(tm) 7550 Dual-Core Processor
    Motherboard
    nVidia MCP78/77/72
    Memory
    8.00 GB
    Sound Card
    nVidia nForce 10/100 Mbps Ethernet
    Monitor(s) Displays
    1600X900 32-bit, 60 Hz LG W2043 Digital
    Other Info
    sorry ran out of time was not able to complete

GaryLee

New Member
Messages
1
#12
mpbaltierra post.

First of all I would like to thank mpbaltierra post. I am using vista home premium 64bit. I had update installer errors.... 643 windows installer cannot be acessed. Tried for days to install new version of windows live and windows updates. Searched and googled nothing worked.
Found this post tried it. Followed the steps and in 5 minutes everything began to install for me. Thanks again Marge.
 

My Computer

Messages
2
#13
:) Hi Gary...I am so pleased that this worked for you also. I'm not a geek or a techie or an expert but I am very good about researching and repairing my own pc problems and even done a few hardware repairs like installing a NIC, changing the inverter on my laptop's monitor when it seemed to have "burned out"...But that 643 error had me stumped. I struggled with it for 3 days. I wanted everything running correctly so I could install Windows 7 on my brand new desktop. So you can imagine HOW HAPPY I WAS, when I found that solution. God bless the clever person who figured out the solution!!! I would still be sitting here trying to find a fix had it not been for him/her!! Well anyhow, I'm so excited that it worked for you too. Happy Trails...
Margie/SF-Calif
 

My Computer

System One

  • Manufacturer/Model
    HP Pavillion Model p6115y
    CPU
    AMD Athlon(tm) 7550 Dual-Core Processor
    Motherboard
    nVidia MCP78/77/72
    Memory
    8.00 GB
    Sound Card
    nVidia nForce 10/100 Mbps Ethernet
    Monitor(s) Displays
    1600X900 32-bit, 60 Hz LG W2043 Digital
    Other Info
    sorry ran out of time was not able to complete

Users Who Are Viewing This Thread (Users: 1, Guests: 0)