Windows Media Player doesn't open media files on double click

Gatoulis

Member
Hi everyone!

When I find a media file (video file, for example) and double click it, the Media Player doesn't start at all...

I tried to re-associate the Windows Media Player to it's default media extensions through "Default Programs" , and it doesn't work...

All media files play normally on other players. I have to state that sometimes I get the message: "The file.... The parameter is incorrect".

Any help would be greatly appreciated. God bless guys! Take care! :)

OS: Vista 32 bit
 

My Computer

whs

Vista Guru
Gold Member
What are the filetypes for those Video files? Maybe it's a Codec problem.
 

My Computer

System One

  • Manufacturer/Model
    Dell
    CPU
    Q6600
    Memory
    4GB
    Monitor(s) Displays
    HP w2207h
    Hard Drives
    2x250GB HDDs
    1x60GB OCZ SSD
    6 external disks 60 to 640GBs
    Occupation
    Retired
    Other Info
    Also 1xHP desktop, 1xHP laptop, 1xGateway laptop
    Country Flag
    germany
    State/Region Flag
    us florida

Ashvin Busviah

Vista Guru

My Computer

System One

  • Occupation
    Technical Support
    Country Flag
    newzealand

Gatoulis

Member
Hi guys and thanks a lot for your quick responses!

@ Whs: File types: avi, mpg, mpeg, wmv

@ ashvin: When I open the context menu, "Open With", "Windows Media Player" the media player doesn't start and shows the message: "The parameter is incorrect"

I have the latest version of Media Player installed, I always used "K-Lite Codec Mega Pack" with no problem, except now. I already re-installed "K-Lite" and no solution...
 

My Computer

Ashvin Busviah

Vista Guru
do you get that error with all the video files or only some?? If its only some then something is wrong with the video but I think still it can be played on vlc player
if you are getting it will all video files then the wmp is corrupted..
Either a system restore may help or the work around is to open windows media player first then click on open.. browse to the video and open it..
 

My Computer

System One

  • Occupation
    Technical Support
    Country Flag
    newzealand

Gatoulis

Member
I get the error on all video files my friend....I cannot restore my system cause it's been 3 months since I had this problem and I did all the updates of Windows, so as to fix it...

This may sound stupid, but I cannot find in the Microsoft site, where to download the Media Player 11...I searched everywhere...:huh:
 

My Computer

Ashvin Busviah

Vista Guru
Windows Media Player 11
you will still have the same problem even if you install this version.. had you tried opening the wmp first the click on file open.. then browse to the video file.. does this works.. ??
 

My Computer

System One

  • Occupation
    Technical Support
    Country Flag
    newzealand

Gatoulis

Member
When I first open the WMP and then the file, it works...

I really can understand why this is happening. I see that MANY people have the same problem..damn... :(

I will try to re-install WMP 11. I will keep you posted my friend, thanks a lot!
 

My Computer

Ashvin Busviah

Vista Guru
its the path of wmp broken.. only a restore or with some chance a windows repair might solve it.. but downloading a later version is just upgrading it on the same broken path.. trying not to be technical.. lol
 

My Computer

System One

  • Occupation
    Technical Support
    Country Flag
    newzealand

whs

Vista Guru
Gold Member
You could also try sfc /scannow in elevated command prompt. Maybe it can fix it. Your phenomenon is not normal. At least the .wmv files should open without problems. They are Vista basics.
 

My Computer

System One

  • Manufacturer/Model
    Dell
    CPU
    Q6600
    Memory
    4GB
    Monitor(s) Displays
    HP w2207h
    Hard Drives
    2x250GB HDDs
    1x60GB OCZ SSD
    6 external disks 60 to 640GBs
    Occupation
    Retired
    Other Info
    Also 1xHP desktop, 1xHP laptop, 1xGateway laptop
    Country Flag
    germany
    State/Region Flag
    us florida

Ashvin Busviah

Vista Guru
hi whs.. hey trying to find the solution.. but can't.. you reakon the path is a registry link broken?
 

My Computer

System One

  • Occupation
    Technical Support
    Country Flag
    newzealand

whs

Vista Guru
Gold Member
hi whs.. hey trying to find the solution.. but can't.. you reakon the path is a registry link broken?

The path seems to be broken somewhere between Open and WMP.
 

My Computer

System One

  • Manufacturer/Model
    Dell
    CPU
    Q6600
    Memory
    4GB
    Monitor(s) Displays
    HP w2207h
    Hard Drives
    2x250GB HDDs
    1x60GB OCZ SSD
    6 external disks 60 to 640GBs
    Occupation
    Retired
    Other Info
    Also 1xHP desktop, 1xHP laptop, 1xGateway laptop
    Country Flag
    germany
    State/Region Flag
    us florida
Top