Windows Update Error 80070002

Aerou

New Member
Greetings.

I've ran into a problem recently. I find myself in a situation where I need to update my current operating system - Windows Vista Home Premium (x64) - from Service Pack 1 to Service Pack 2.

Now, normally (afaik) this would be achieved using the Windows Update tool but in my case it does not seem to be working. It tries to install the update but near the end it stops with an error '80070002'.

I've tried these Microsoft guides referring to error 8007002 (didn't fix my problem though):

Windows Update error 80070002

How do I reset Windows Update components?

Now, the first link asks me to download the System Update Readiness Tool. There is a big notification on the download page that says "The support for Vista without SP2 has been discontinued.." etc. So, I'm not sure that the tool even works for me anymore. Nevertheless, I downloaded it and after a lengthy loading screen it did say that the tool was installed. After booting my PC, I still received the update error though.

Besides those guides, I've read on other threads that registry errors might be the cause for my update problems. I've done a System File Checker scan and it said that it found some defective files but it couldn't fix them. Also, it referred to a .log file for more infromation but unfortunately I have no way of deciphering the file.

I've also downloaded the Service Pack manually and tried to install it but I keep receiving an error as well. I even went as far as to try the installer in Window's safe mode but that didn't work either.

So, I find myself frustratedly at a loss. I've done Google searches on the subject for hours but nothing seems to be fixing the issue. I'm aware that this forum contains many threads with the same subject as mine and I've been through most of them. Yet, they did not help me resolve the error I keep receiving. I'd love to find a solution without having to install Vista all over again on my computer (or a W7 upgrade).

As you've noticed, I'm quite clueless when it comes to these things and any help you can offer is extremely appreciated.

EDIT: I've attached my CBS and CheckSUR log files.
 

Attachments

  • CheckSUR.log
    4.1 KB · Views: 31
  • CBS.zip
    1.3 MB · Views: 10
Last edited:

My Computer

System One

  • Name
    Samuli
    CPU
    Intel Core2 Quad CPU Q9550 @ 2.83GHz (4 CPUs), ~2.8GH
    Motherboard
    P5Q-PRO, ASUSTeK Computer INC.
    Memory
    4094MB RAM
    Graphics Card(s)
    ATI Radeon HD 4800 Series

richc46

Vista Guru
Gold Member

My Computer

System One

  • Name
    Richard
    Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT
    Country Flag
    usa
    State/Region Flag
    us connecticut

Aerou

New Member
First of all, thanks for the fast reply Richard.

I've actually tried the solution that you linked, as I mentioned in my first post. I couldn't seem to make it work though. The automated troubleshooter ("Fix it") did not fix anything, keep getting the same error after trying it. As for manually resetting the Windows Update components, I ran into a few problems. Allow me to explain:

Fist of all, the command "net stop wuauserv" does not work for me. It tries to stop the service but fails and after that the service stops functioning. Dunno what that's about and I've had to reboot my PC to get it running again. To fix this, I stop the service myself without using the Command Prompt. That seems to work.

At section 4. a. none of the commands worked for me. In the case of the "SoftwareDistribution\DataStore" and "SoftwareDistribution\Download" folders I assumed that the procedure is the same as in the "Windows Update error 8007002" article, I.E. deleting the contents of said folders. I could not do anything to the "\system32\catroot2" folder, supposedly I am not priviledged.

I had error messages with these .dll files at section 6. (regsvr32.exe):

mshtml.dll
shdocvw.dll
browseui.dll
msxml.dll
gpkcsp.dll
sccbase.dll
slbcsp.dll
initpki.dll
wuaueng1.dll
wucltui.dll
wuweb.dll
qmgr.dll
muweb.dll

Despite these errors I procedeed forward.

Section 7. and the command "netsh reset winsock" gave me a reply of "could not find command: reset winsock" despite multiple tries.

I suppose everything else worked as it was supposed to. I installed the Windows Update Agent (How to obtain the latest version of the Windows Update Agent to help manage updates on a computer) as commanded and restarted my computer.

After all this I tried running Windows Update and it still gives me the same error.
 
Last edited:

My Computer

System One

  • Name
    Samuli
    CPU
    Intel Core2 Quad CPU Q9550 @ 2.83GHz (4 CPUs), ~2.8GH
    Motherboard
    P5Q-PRO, ASUSTeK Computer INC.
    Memory
    4094MB RAM
    Graphics Card(s)
    ATI Radeon HD 4800 Series
Top