• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows update error 80070490

Hi, I'm hoping someone can help me here please.

I've got this error coming up on Windows Update. 80070490. I have tried the Readiness Tool suggested on the Microsoft site but it has not fixed the error. I cannot re-install Windows since the laptop didn't come with a disk (OS pre-installed - hate that.)

Please help me.


Staff member
Vista Guru
Gold Member
The method to reinstall without a DVD does not seem to apply to your computer. You can research further yourself, using your manual and lookifng for a restoration partition. Im surprised that your computer does not seem to have one.

In any event try these methods to fix your problem.

How do I reset Windows Update components?
Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, for Windows 7, and for Windows Server 2008 R2
Cannot Update Windows using Windows Update

Try these one should get you working, again
Many thanks Richc46, but I had already tried the top two with no result. I've just finished working my way through the options on the page the third link sent me to, and again, it still does not work.

It seems to be consistently failing to update on 12 updates. Can I manually update them and bypass WU?
What you want to do is set updater to notify and not install. Then install one at a time. The few that are left may not be needed.
For the 11 that you do not want to install, initially, right click on each update and then set them to hide
I've done that for years. Never let anything install itself on my machines. What I meant was, was there a way to install updates without using the Windows Update at all?

Of the 12 updates...

4 are labelled Update for Vista.
5 are labelled Security Update for Vista
2 are labelled Security Update for .net, Vista SP1, Vista SP2, Vista Server... etc
1 is labelled Cumulative Security Update for IE9

...so I'm guessing I pretty much need them all.

However, I have not tried getting WU to install them singularly, so I will try that.

Thanks once again for your help Richc46