• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Update Error Code 643

#1
Hello all I am scouring the internet for answers but I can't seem to find any so I thought I should ask the Gurus down at the Windows Vista Forums.:D Anyways I am trying to install the Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86 and all I get is this error. Does anyone know how I can fix this?
 

Martee

Vista Die-Hard
Vista Guru
#2
Hello Peacemaker,

When you try to install an update for the .NET Framework 1.0, 1.1, 2.0, 3.0, or 3.5, you may receive Windows Update error code "0x643" or Windows Installer error code "1603"

RESOLUTION

To successfully install the update, uninstall all the versions of the .NET Framework on the computer, and then reinstall all the versions of the .NET Framework on the computer. You may have to work through more than one of the following methods.

Method 1: Manually remove and reinstall .NET Framework
To manually remove and reinstall the .NET Framework, follow these steps:

1. Remove the .NET Framework.
1. Click Start, and then click Control Panel.
2. Double-click Add or Remove Programs.
3. Note each version of the .NET Framework that is already installed on the computer. Then, uninstall all the versions of the .NET Framework.
4. When you are prompted, restart the computer.


Method 2. Use the Windows Installer CleanUp Utility to clean up the MSI database state for all the versions of the .NET Framework.

1. Download the Windows Installer CleanUp Utility. The following file is available for download from the Microsoft Download Center: http://download.microsoft.com/download/e/9/d/e9d80355-7ab4-45b8-80e8-983a48d5e1bd/msicuu2.exe
2. Install the Windows Installer CleanUp Utility as an administrator or as a user account that is a member of the local Administrators group.
3. Click Start, point to All Programs, and then click Windows Install Cleanup.
4. In the Windows Installer CleanUp Utility, remove all Windows Installer applications for the .NET Framework.
3. Restart the computer.


Download and then reinstall all the versions of the .NET Framework that were previously installed on the computer.


 
#4
I've tried everything and it still won't work. Also I should say that I uninstalled .NET 3.5 to install the drivers on my printer but when I tried to reinstall it doesn't work.
 
#5
I've tried everything and it still won't work. Also I should say that I uninstalled .NET 3.5 to install the drivers on my printer but when I tried to reinstall it doesn't work.
1.Neverless use NET Framework Cleanup Tool to make sure you have completely removed 3.5.
2.If you had trouble with drivers to printer it could be also source of your problem -uninstall these drivers.
3.Run cmd.exe with administrative previlliges (right click on this file as admin) and type

sfc /scannow

4.If still nothing help run CheckSur tool Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008, for Windows Server 2008 R2 Release Candidate, and for Windows 7 Release Candidate
If this tool also can't resolve problem attache to post logs of this program.These should be C:\Windows\Logs\CBS\CheckSUR.log
It will worth also attache sfc logs:
Run cmd.exe with administrative previlliges and type

findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >%userprofile%\Desktop\sfcdetails.txt

on your desktop appear file sfcdetails.txt.Both CheckSUR.log and sfcdetails.txt attache to post
 
#6
It is interesting to see that there are instruction that the earlier versions must be removed prior to installing the new .NET but there is no waring of this in the Windows Update. It just fails to install. I used option Number One above, rebooted and ran the updater. Then confirmed via add remove that it was in fact installed. Thanks Folks it worked, as my Gramps would say, Finer than Frog Hair! LOL
____________________________________________________________________
Here is the little notice at:
Download details: .NET Framework 3.5
IMPORTANT:
  • If you have installed earlier pre-release versions of .NET Framework 3.5, then you must uninstall them prior to running this installation by using Add or Remove Programs.
    For more details on this release of the framework, see the following references:
    Visual Studio 2008 Learn More
    .NET Framework Developer Center
 
#7
I solved my error code 643 problem by temporarily turning off user account control.
It's probably not the ideal solution, but it's the only thing that worked for me.
 
#8
Hi,
Turn off User account.
Do a clean boot.
Download the .net framework clean up utility and run it twice.
Restart the computer.
Delete the file and folders in temporary folder and prefetch.
Do a disk cleanup.
Download the .net framework 4 from microsoft.com.downloads and install it.

I bet this would fix the issue for you.
 
#9
i had this problem and no windows cd it was related to corrupt service files. SFC /scannow required the cd so i had to use reimage to reinstall windows over the interent.

Jope this is helpfull to others.