Windows update "the page failed to load"

drelectron

New Member
Vista Home Basic SP2. When I try to run Windows update all I get is a blank page that says "The page failed to load". I've looked all around and have found a lot of people with the same or a similar problem but no firm solutions. I haven't used it in maybe a week and it's worked fine up till now. There have been no real changes since I used it last. Does anyone have a clue?
 

My Computer

System One

  • Manufacturer/Model
    Custom built
    CPU
    Intel E4300
    Motherboard
    Gigabyte GA-G33M-S2
    Memory
    CORSAIR XMS2 2 x 2GB PC6400
    Graphics Card(s)
    Radeon HD 2600 XT
    Monitor(s) Displays
    Westinghouse 22" LCD
    Screen Resolution
    1680x1050
    Hard Drives
    Samsung 320GB
    Mouse
    Microsoft wireless
    Keyboard
    Microsoft wireless
    Internet Speed
    DSL

Flavius

Expelled
Does anyone have a clue?

Many possible explanations -wrong system settings,3p software,viruses...

Try advices from this link:You cannot install some updates or programs
reset IE http://www.vistax64.com/tutorials/114310-internet-explorer-reset.html

Uninstall non-system firewall,antivirus,antispyware

Reset WU with "aggressive mode" How do I reset Windows Update components?

Viruses also cancause this.Because scanning on allive system is not credible because many viruses can hide before antivirus I suggest use LiveCD with antivirus for example this one Dr.Web LiveCD is a software product that features a standard, Dr.Web scanner ,burn boot it and scan.
If nothing help find WindowsUpdate.log file in C:\Windows pack it and attache to post.
 

My Computer

drelectron

New Member
Thanks Flavius. After some serious hunting around I found the problem. It has to do with Windowblinds. Anyone else with this or a similar problem see the bottom of this page Windows Update page failed to load
 

My Computer

System One

  • Manufacturer/Model
    Custom built
    CPU
    Intel E4300
    Motherboard
    Gigabyte GA-G33M-S2
    Memory
    CORSAIR XMS2 2 x 2GB PC6400
    Graphics Card(s)
    Radeon HD 2600 XT
    Monitor(s) Displays
    Westinghouse 22" LCD
    Screen Resolution
    1680x1050
    Hard Drives
    Samsung 320GB
    Mouse
    Microsoft wireless
    Keyboard
    Microsoft wireless
    Internet Speed
    DSL

chopperchick

New Member
Vista Home Basic SP2. When I try to run Windows update all I get is a blank page that says "The page failed to load". I've looked all around and have found a lot of people with the same or a similar problem but no firm solutions. I haven't used it in maybe a week and it's worked fine up till now. There have been no real changes since I used it last. Does anyone have a clue?


I was having the same issue and found a solution.....In my case I have windowblinds installed so I opened windowblinds and changed the blind to windows aero then opened windows update again and it worked. If you have windowblinds installed this should work for you.
 

My Computer

Top