• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Vista Home Premium - Install Update Problems

#1
Newbie here, so please be patient. :)

A few days ago I saw I had 11 updates ready to be installed. 3 of them were successful 7 were not. The unsuccessful were Office 2007:
KB946974 (Excel)
KB946691 (Office)
KB947801 (Office)
KB950378 (Office)
KB951808 (Office)
KB950114 (Publisher)
KB950113 (Word)

I received an error: Error details: Code 57A.

I tried multiple times to install, all with the same error. I did try downloading the update to my desktop, and install with the option "run as administrator...no luck.

I am running Windows Vista Home Premium. Anyone offer assistance?

Thanks
 

My Computer

#3
What is the file name of the temp file you are referring to? Also, how does one take ownership of the reg tree? I've dabbled in the registry, but am not 100% sure what you are referring to....exact steps would be appreciated.

Thanks.
 

My Computer

sidney1st

Member
Vista Guru
#4
You have first to examine the msi*.log files in the temp folder.
msi* means that the files start with msi and * is i think a random sequence.
The log file will tell you why the update failed, often it comes from an access problem with a reg key.
If it is the case, open regedit and take ownership of the reg tree of the key found in the log file (right click/permissions) a dialog box similar to the security tab of a file will open.
Then take ownership of the reg tree and allow to system the control of the reg tree.
 

My Computer

#5
I found the msi log. There was a key identified in the log that I could not access. I made the changes, tried to re-install and it worked for some of the updates. I went back into the latest log file to determine why the other updates failed, and now cannot access a different key:
HKEY_LOCAL_MACHINE\Software\Classes\MailFileAtt\CLSID

When I first try to edit the entry, I get the following message:
You do not have permission to view the current permission settings for CLSID, but you can make permission changes.

I received the same error message when altering the first key, but proceeded anyway, and was successful. This time I was not successful.

I tried to change permissions, but received this error:

"Unable to save permission changes on CLSID. Access is denied."

I also have problems with updating other software (i.e. iTunes), due to permissions of registry keys. Could it be due to how I set up Vista initially? I have only one user on this PC, and it is an admin. Is this proper? If so, what do you suggest for the next steps to resolve my update problems?

Can anyone offer assistance?
Thanks.
 
Last edited:

My Computer