Audio Device - Enable Hidden Devices

ByLine
How to Enable Hidden Audio Devices in Vista and Windows 7
Synopsis
This will show you how to enable hidden disabled audio devices in the Sound Control Panel window so they will be available to use now.
How to Enable Hidden Audio Devices in Vista and Windows 7

information   Information
This will show you how to enable hidden disabled audio devices in the Sound Control Panel window so they will be available to use now.
Note   Note
These now enabled audio devices will also now be available to all programs that allow you to select audio devices.
Tip   Tip
Enabled the Stereo Mix device, if you have this option, will allow you to record all sounds played on your computer using Sound Recorder without a microphone.




Here's How:
1. Open the Control Panel. (Classic View)​
NOTE: Open the Start menu and click on the Control Panel menu button.​
2. Click on the Sound icon.​
3. Click on the Recording tab. (See screenshot below step 4)​
NOTE: This will also work in the Playback tab, but there is usually not any hidden audio devices there.​
4. Right click on a empty area and click on Show Disabled Devices.​
Sound1.jpg

5. You will now see the disabled audio devices with the arrow pointing down on them. (See screenshot below)​
NOTE: These audio devices will vary depending on the installed audio card or chip you have.​
Sound2.jpg

6. Right click on each listed disabled audio device that you want to enable and click on Enable. (See screenshot below)​
Enable.jpg

7. You will now see this when the audio devices are enabled. (See screenshot below)​
NOTE: You can now change the properties settings on these audio devices to how you want them.​
8. Click OK to close the Sound window.​
Sound3.jpg

That's it,
Shawn


 
Last edited by a moderator:
Shawn Brink

Comments

Thanks for this advice, however I still am only seeing the microphone and speakers. The sound card is not showing at all. I have Intel(R) High Definition Audio HDMI on my HP laptop, running Vista Home Premium 32 bit. I have also revealed hidden/ghost devices in device manager, but the sound card appeared even before I did this and it still doesn't appear in the control panel despite following the above tutorial.

Any ideas why this might not be coming up and what I can do to fix it? I'm trying to record from an audio stream, and need to enable this to be able to do this.

Thanks in anticipation.
 
Last edited:
Hello Frannie, and welcome to Vista Forums.

Usually if the sound card is not showing in Device Manager, you will need to install or reinstall the drivers for the sound device.

What model is your HP laptop? I may be able to help find the drivers for you at HP's website.
 
Hello Brink -

well, that's the problem really. The sound card is showing in device manager, but not in the sound control panel even after clicking on 'show disabled devices'. I've uninstalled and reinstalled it as you suggested, but this hasn't made a difference. I'm at a bit of a loss on this one.

FYI, the HP model is a Compaq Presario CQ60 Notebook PC.
 
The disabled audio devices in the screenshots in the tutorial are just features of my sound device. Not all sound devices will have the same features or disabled audio devices as this though. Could you post a screenshot of what you are seeing to see if it may help more?
 
Hi Brink, is there a way to enable a way of recording the sound in the computer without using a microphone, in xp i could have done that, but not in vista..
 
Hello Vortex,

You should be able to record sounds played on the computer using Sound Recorder at C:\Windows\System32\SoundRecorder.exe.
 
Thnx for replying so fast :) , but what i ment was like when i play a music, it records what happends on the desktop not via the mic, if i put my mic on the speakers it won't record the sound perfectly, if you know what i mean :)...
 
Hi

I just wanted to say Thank You for loading this post, as I would never have thought to look for the hidden disabled devices like this.... why on earth did they do this????

Anyway, thanks.

MomC :D
 
You're most welcome MomC, and welcome to Vista Forums.

I'm not sure why they are not just enabled by default either. :confused:
 
Top