Boot Up Time

ByLine
How to See What Your Boot Up Time is in Vista
Synopsis
To optimize the boot/shutdown of Windows, it is necessary to know precisely the reboot time of the computer to be able to refine its adjustments.
But rather than having the hand on a stop watch at the time of the reboot, better use this easy way. You will appreciate how simple it is to use.
How to See What Your Boot Up Time is in Vista

information   Information
To optimize the boot/shutdown of Windows, it is necessary to know precisely the reboot time of the computer to be able to refine its adjustments.
But rather than having the hand on a stop watch at the time of the reboot, better use this easy way, You will appreciate how simple it is to use and the precision of the result.

The relative time value will then give you a point of comparison to optimize the boot/shutdown of your computer.
Note   Note
For fun you can post your results here: ReBoot Time

EXAMPLE: ReBoot-Time dialog box
NOTE:
This is what you will see after running the VB Script file from below and when you computer finishes restarting.

ReBoot_Time.jpg
Here's How:
information   Information
In order to calculate the time of rebooting Windows, we will use a VB Script (Visual BASIC Scripting Edition). Let us learn first how it works.

The script writes a value in the registry (HKCU \ Software \ Microsoft \ Current Version \ run) so that it can be started again when booting. Then, another value containing the time is writen in the registry when the reboot is launched. While rebooting, the script records the hour in a variable then checks if the first value containing the time exists. If so, it is then enough to compare two times in order to obtain the time of rebooting. Then, the two keys added in the registry are removed (the run key and the key where the time is stored).

1) Open your favorite text editor (notepad will do the job perfectly) and copy/paste the following script:

Code:
Option Explicit
On Error Resume Next
Dim Wsh, Time1, Time2, Result, PathFile, MsgResult, MsgA, AppName, KeyA, KeyB, TimeDiff
MsgA = "Please close all running applications and click on OK."
KeyA = "HKEY_CURRENT_USER\Software\RestartTime\"
KeyB = "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run\RestartTime"
AppName = "ReBoot-Time"
Set Wsh = CreateObject("WScript.Shell")
PathFile = """" & WScript.ScriptFullName & """"
Result = wsh.RegRead(KeyA & "Times")
if Result = "" then
MsgResult = Msgbox (MsgA, vbOKCancel, AppName)
If MsgResult = vbcancel then WScript.Quit
Wsh.RegWrite KeyA & "Times", left(Time,8), "REG_SZ"
Wsh.RegWrite KeyB, PathFile, "REG_SZ"
Wsh.Run "cmd /c Shutdown -r -t 00", false, 0
else
Wsh.RegDelete KeyA & "Times"
Wsh.RegDelete KeyA
Wsh.RegDelete KeyB
TimeDiff = DateDiff("s",Result,left(Time,8))
MsgBox "Your computer reboots in " & TimeDiff & " seconds", VbInformation, AppName
end if
wscript.Quit

2) Save the file wherever you want on the same HDD (desktop for example) as ReBoot-Time.vbs (you can choose whatever name as far as the extension is ".VBS".

You can also download the script file here:

download < Click to Download


Use of the Script:
  • Double click on the script icon if it is on your desktop or on the file if you saved it in a particular folder.
  • Close all the running applications and click the OK button in the dialog box.
  • The computer will reboot and when Windows will be ready to be used, a new dialog box will open displaying the time your computer took to reboot.
Voila!


 

Attachments

  • bootspeed.vbs
    961 bytes · Views: 13,059
  • thumb_Bootscreen.jpg
    thumb_Bootscreen.jpg
    1.6 KB · Views: 186
Last edited by a moderator:
I can't get this thing to work. I downloaded it to a folder and closed all open apps and clicked open/run and all i get it the note pad page from the post. What am I doing wrong?

Hi Bassfisher,

You must have associated .vbs files with notepad, just use Sidney1st`s reboot-time executable instead ;)

download

Steven
Ok got it, thanks. I ran it and it popped up and said it took 166 seconds to boot. Seems like a long time. Next question; where do I find that popup again of my boot up time, so I can post it. What can I do to cut this time down?
 

My Computer

System One

  • Manufacturer/Model
    Self built
    CPU
    AMD Athlon 64x2 6000+ 3.0ghz
    Motherboard
    Asus M4N78 Pro
    Memory
    3Gb PC2-5300 DDR2 @ 667mhz
    Graphics Card(s)
    XFX Radeon HD 4770 512mb GDDR5
    Sound Card
    VIA HD Audio
    Monitor(s) Displays
    Dual monitors: HP W1907 LCD 19" and Gateway HD Display 19" LCD
    Screen Resolution
    1440x900
    Hard Drives
    Barracuda 7200.10 SATA 3.0Gb/s 320 x 2-GB Hard Drive
    PSU
    Antec Earthwatts 80 plus 500 watts
    Case
    Ultra E-Torque ATX Mid tower clear side w/2 120mm fans
    Cooling
    Thermaltake MaxOrb cpu cooler w/120 mm blue led
    Mouse
    OEM HP
    Keyboard
    OEM HP
    Internet Speed
    Download 6885 kb/s upload 367 kb/s
    Other Info
    Optical: Super Muliti DVD burner w/lightscribe, Hauppauge WinTV HVR-1800

Brink

Staff member
mvp

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

locoeng

Flim-Flam Man
Vista Guru
Hi Donta...I'll check Avira when I get home.
 

My Computer

System One

  • Manufacturer/Model
    Homebrew
    CPU
    Q6600 (G0) SLACR
    Motherboard
    Gigabyte EP35 DS3R
    Memory
    2 gigs G.Skill DDR2
    Graphics Card(s)
    XFX 8600GT
    Monitor(s) Displays
    Samsung T190 1440X900
    Screen Resolution
    1440X900
    Hard Drives
    2X Seagate 120 (OS's) IDE
    1X WD 750 SATA
    PSU
    Corsair HX520
    Case
    Coolmax el cheapo
    Cooling
    Rosewill HSF (soon to upgrade)
    Keyboard
    BTW low profile backlit/quiet key

KarelessK

New Member
Thanks for this much appreciated. The first I ran the script I had left a DVD in the drive and on re-boot the system was constantly trying to seek and read the DVD. I took it out and it continued without error (in the BIOS the HD is set as the first device). Ran the script a second time (without DVD) and it took 40 seconds off!

Do you know if the time displayed includes the time it takes you to login (ie type your password)?
 

My Computer

System One

  • CPU
    Q6600
    Motherboard
    Asus P5Q Pro (BIOS 0506)
    Memory
    2x2GB Corsair XMS6400
    Graphics Card(s)
    Sapphire 4870
    Hard Drives
    Samsung 750GB F1

Brink

Staff member
mvp

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

KarelessK

New Member
Thank you Brink

It all just went horribly wrong!

I used the tutorial to change from 1 core to 4 in msconfig and instead of allowing the restart I exited and then tried to run the script. Windows re-booted fine and then just after if gave me my time the mouse and keyboard froze. These are both fitted via usb.

I have spent the last hour trying to resolve this by running system restore - no luck. Restarting in safe mode (all works fine) and deleting the script but when ever I return to normal windows same fault appears although the "time to reboot" popup does not appear.

My system is only 2 weeks old so all data is elsewhere and am looking to do a reinstall now. About to search for a good tutorial!
 

My Computer

System One

  • CPU
    Q6600
    Motherboard
    Asus P5Q Pro (BIOS 0506)
    Memory
    2x2GB Corsair XMS6400
    Graphics Card(s)
    Sapphire 4870
    Hard Drives
    Samsung 750GB F1

Brink

Staff member
mvp
KarelessK,

While you are in Safe Mode, change the CPU core back to 1 in msconfig, then restart to see if it will start normally for you.

If not, then you might try reinstalling your mouse and keyboard drivers while in Safe Mode.

Hope this helps,
Shawn
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

KarelessK

New Member
Thanks Shawn for the swift response.

Have already changed back to 1 core. Not sure where to look for these drivers? On the Vista installation DVD?

Uninstalled drivers then reinstalled - to no avail.

It is even more bizarre. The problem does not replicate itself in another account?

Ooops - I lied. The fault has reoccured in other accounts.
 

My Computer

System One

  • CPU
    Q6600
    Motherboard
    Asus P5Q Pro (BIOS 0506)
    Memory
    2x2GB Corsair XMS6400
    Graphics Card(s)
    Sapphire 4870
    Hard Drives
    Samsung 750GB F1

Brink

Staff member
mvp
KarelessK,

With all the various problems you are having, it may be best to do a clean reinstall. :(
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

KarelessK

New Member
Just completed my clean install...phew that was hard work. Made more difficult by the fact I had a dodgy DVR RW which was very tempermental - now I have replaced it everything seems to be working as normal,
 

My Computer

System One

  • CPU
    Q6600
    Motherboard
    Asus P5Q Pro (BIOS 0506)
    Memory
    2x2GB Corsair XMS6400
    Graphics Card(s)
    Sapphire 4870
    Hard Drives
    Samsung 750GB F1

Brink

Staff member
mvp
KarelessK, I'm happy to hear that everything seems to be working fine now. Thank you for the feedback.

Shawn
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

oxicottin

Member
Well I got a box that says 1192 :confused: I knew something was wrong when it takes forever to to shut down and open my PC. I did it a second time and got 219, Whats next? How do I get a lower shut down and start times?

Thanks,
Chad
 
Last edited:

My Computer

Brink

Staff member
mvp
Hello Chad,

The hanging issue must have resolved itself when you ran it the second time. I would say that the 219 would be your average boot up time. The Related Links at the top of this tutorial will help show you how to improve your computers performance and decrease those times.

Hope this helps,
Shawn
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro 64-bit
    Manufacturer/Model
    Custom
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G7 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 970 EVO Plus M.2,
    250GB Samsung 960 EVO M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3
    Cooling
    Corsair Hydro H115i
    Mouse
    Logitech MX Master 3
    Keyboard
    Logitech wireless K800
    Internet Speed
    1 Gb/s Download and 35 Mb/s Upload
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Arris SB8200 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Lumia 1520 phone
  • Operating System
    Windows 10 Pro
    Manufacturer/Model
    HP Envy Y0F94AV
    CPU
    i7-7500U @ 2.70 GHz
    Memory
    16 GB DDR4-2133
    Graphics card(s)
    NVIDIA GeForce 940MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    17.3" UHD IPS touch
    Screen Resolution
    3480 x 2160
    Hard Drives
    512 GB M.2 SSD

oxicottin

Member
Thanks Brink! I read the link on shortening the shutdown time it involved changing the paging file and I didnt quite understand what that file was for and what happened if I changed it.

Thanks,
Chad
 

My Computer

Top