Desktop Background Wallpaper - Prevent Change

ByLine
How to Enable or Prevent the Desktop Background Wallpaper from being Changed in Vista
Synopsis
This will show you how to enable or prevent the change of Desktop Backgrounds. You can set a default optional Desktop Background Wallpaper of your choice for all user accounts, and prevent it from being changed.
How to Enable or Prevent the Desktop Background Wallpaper from being Changed in Vista

information   Information
This will allow you to set a default optional Desktop Background Wallpaper of your choice for all user accounts, and prevent it from being changed.
Note   Note
STEP ONE below will just remove the Desktop Background option from the Personalize appearance and sounds screen. Users will still be able to change the wallpaper by right clicking on a image and click Set as Desktop Background. You must also do STEP TWO below to prevent the desktop background from being changed. You will have a choice to do this using METHOD ONE or METHOD TWO on below.
Tip   Tip
If you have a blank or solid background, then check this setting to make sure it is unchecked:
  • Open the Control Panel (classic view).
  • Click on the Ease of Access Center icon.
  • Click on the Make the computer easier to see link.
  • Uncheck Remove background images (where available) box.
  • Click on Save.
warning   Warning
If you did not disable the ability to change the desktop background, then you may be infected with some form of malware on your computer. I would recommend that you run a very thorugh antivirus and spyware scan to help make sure that your computer is clean.

EXAMPLE:
NOTE:
This will be removed in STEP ONE below.

Desktop_Background.jpg





METHOD ONE
Through the Local Group Policy Editor




Step One
Remove or Show the Desktop Background Option
Note   Note
STEP ONE will just remove the Desktop Background option from the Personalize appearance and sounds screen. Users will still be able to change the wallpaper by right clicking on a image and click Set as Desktop Background. You must also do STEP TWO below to prevent the desktop background from being changed.
1. Open the all users, specific users or groups, or all users except administrators Local Group Policy Editor for how you want this policy applied.​
2. In the left pane, click on User Configuration, Administrative Templates, Control Panel, and Display.​
(See screenshot below)​
Group_Policy2.jpg
3. In the right pane, right click on Prevent changing wallpaper and click on Properties. (See screenshot above)​
4. To Show the Desktop Background Option
A) Select (dot) Disabled or Not Configured and click on OK. (See screenshot below step 5A)​

5. To Remove the Desktop Background Option
A) Select (dot) Enabled and click on OK.​
Prevent_Properties.jpg




Step Two
Disable or Enable Changing the Desktop Background
Note   Note
This will also disable the Set as Desktop Background option for when a user right clicks on a image. The option will not be grayed out, but it will not work unless this is enabled.
6. In the left pane, click on User Configuration, Administrative Templates, Desktop, and Desktop.​
(See screenshot below)​
7. In the right pane, right click on Desktop Wallpaper and click Properties.​
Group_Policy1.jpg

8. To Enable Changing Desktop Background
A) Select (dot) Disabled or Not Configured and click on OK. (See screenshot below step 9D)​
B) Go to step 10.​

9. To Disable Changing Desktop Background
A) Select (dot) Enabled. (See screenshot below step 9D)​
B) In the Wallpaper Name: box, type in the full path of a wallpaper you want displayed for all user accounts. (See screenshot below step 9D)​
NOTE: You can only use a .BMP or .JPG image. If you just want a blank wallpaper, you can enter a invalid path. (EX: C:\ )
C) In the Wallpaper Style: box, select if you want the wallpaper to be in Center, Stretch, or Tile style. (See screenshot below step 9D)​
D) Click on OK. (See screenshot below)​
Desktop_Wallpaper_Properties.jpg

10. Close the Local Group Policy Editor window.​
11. Restart the computer to apply the changes.​






METHOD TWO
Using a REG File Download

NOTE:STEP ONE will just remove the Desktop Background option from the Personalize appearance and sounds screen. Users will still be able to change the wallpaper by right clicking on a image and click Set as Desktop Background. You must also do STEP TWO below to prevent the desktop background from being changed.
STEP ONE:
1. To Show the Desktop Background Option
A) download

2. To Remove the Desktop Background Option
NOTE: This will just remove the Desktop Background option from the Personalize appearance and sounds screen. Users will still be able to change the wallpaper by right clicking on a image and click Set as Desktop Background. You must also do STEP TWO below to prevent this.
A) download

STEP TWO:
3. To Enable Changing the Wallpaper
A) download
4. To Disable Changing the Wallpaper
NOTE: This download will give you a blank wallpaper. If you want to disable changing the wallpaper and have a wallpaper of your choice, then see STEP TWO in the Manual section below.​
A) download

5. Click on Save, and save the .reg file to the Desktop.​
6. Right click the .reg file (on Desktop) and click on Merge.​
7. Click on the Run button for Security Warning pop-up.​
8. Click on Continue (UAC), Yes, and then OK when prompted.​
9. When done, you can delete the .reg file (on Desktop).​
10. Log off and log on, or restart the computer to apply the changes.​





METHOD THREE
Manually in Registry Editor

1. Open the Start Menu.​
2. In the white line (Start Search) area, type regedit and press Enter.​
3. If prompted, click on the Continue button in the UAC prompt.​
4. In regedit, go to: (See screenshot below)​
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
Policies_Reg.jpg




Step One
Remove or Show the Desktop Background Option
Note   Note
STEP ONE will just remove the Desktop Background option from the Personalize appearance and sounds screen. Users will still be able to change the wallpaper by right clicking on a image and click Set as Desktop Background. You must also do STEP TWO below to prevent the desktop background from being changed.
5. To Remove the Desktop Background Option
A) In the left pane, right click on Policies and click on New and Key. (See screenshot below step 4)​
NOTE: If you already have the ActiveDesktop key, then go to step 5C.​
B) Type ActiveDesktop and press Enter. (See screenshot below)​
C) In the right pane, right click on a empty area and click on New and DWORD (32 bit) Value.​
ActiveDesktop_Reg.jpg

D) Type NoChangingWallpaper and press Enter. (See screenshot below)​
E) In the right pane, right click on NoChangingWallpaper and click on Modify.​
NoChangingWallPaper.jpg

F) Type 1 and click on OK. (See screenshot below)​
Modify_NoChangingWallpaper.jpg

6. To Show the Desktop Background Option
A) Right click on NoChangingWallpaper and click on Delete. (See screenshot below step 5E)​
B) Click on Yes to confirm Delete.​
C) In regedit, go to: (See screenshot below)​
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
D) In the right pane, repeat steps 6A and 6B if NoChangingWallpaper is there to.​
HKLM_ADD_Reg.jpg





Step Two
Disable or Enable Changing the Desktop Background
Note   Note
This will also disable the Set as Desktop Background option when a user right clicks on a image. It will not be grayed out, but it will not work unless enabled.
7. To Disable Changing the Desktop Background
A) In the left pane, right click on Policies and click on New and Key. (See screenshot below)​
NOTE: If you already have the System key, then go to step 7C.​
Policies2_Reg.jpg

B) Type System and press Enter. (See screenshot below)​
C) In the right pane, right click on a empty area and click on New and String Value.​
System_Reg.jpg

D) Type Wallpaper and press Enter. (See screenshot below)​
E) In the right pane, right click on Wallpaper and click on Modify.​
Wallpaper_Reg.jpg

F) Type in the full path of a wallpaper you want displayed for all user accounts and click on OK. (See screenshot below)​
NOTE: You can only use a .BMP or .JPG image. If you just want a blank wallpaper, you can enter a invalid path. (EX: C:\ )
Modify_Wallpaper.jpg

G) In the right pane, right click on a empty area and click on New and String Value. (See screenshot below)​
H) Type WallpaperStyle and press Enter.​
I) In the right pane, right click on WallpaperStyle and click on Modify.​
WallpaperStyle_Reg.jpg
J) Type in a number below in bold for the wallpaper to be in Center, Stretch, or Tile style, and click on OK. (See screenshot below)​
  • Type 0 to Center the wallpaper on the desktop.
  • Type 1 to Tile the wallpaper on the desktop.
  • Type 2 to Stretch the wallpaper to fit the desktop.
Modify_WallpaperStyle.jpg

8. To Enable Changing the Desktop Background
A) In the right pane, right click on both Wallpaper and WallpaperStyle and click Delete. (See screenshot below step 7I)​
NOTE: You will have to do these one at a time.​
B) Click on Yes to confirm each deletion.​

9. Close regedit.​
10. Log off and log on, or restart the computer to apply changes.​
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

This was very helpful. I have been trying to change my background forever, but I could never figure out what was wrong. Thanks
 
You're welcome Eburns, and welcome to Vista Forums. I'm happy to hear that you got it sorted.

Shawn
 
Hiya,

This is much later the last post I know, but I've a few problems after using the helpful guide here. I'm having troubles like most other people who are writing are, I cannot edit change the background without right clicking on the image and the "Desktop Background" icon has disappeared from the control panel.

I went through the tutorial and tried all of the methods to enable it again, and the reg key I was hoping to find so I could delete it wasn't there. I searched the whole registry for one through the search function and nothing appeared.

Im reluctant to re-install or repair Vista as I dont think I have the CD on me anymore, and this problem has been going on for so long causing me to be reluctant to preform a system restore as I would have to go back to one of the first restore points created!

Any idea's as how to help,
Thanks a lot,
Andy
 
Hi Andy, and welcome to Vista Forums.

Could you post back a screenshots of these locations in your registry. Be sure to include everything in the right pane at these locations. I will see if I can spot the entry that be blocking it for you.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

and

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System


and

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


and

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
 
hey Brink,

After starting my computer up again (despite a restart after all your advice) for some reason its decided to sort itself out now, I can only presume its to do with the advice you gave me, so thanks a lot! :)

Finally I can set myself a screensaver and change my wallpaper in different ways! :party:

Andy
 
I tried the above too but have no ActiveDesktop under polices.
Can I add it somewhere. I have Vista Premium.
Thanks
Korimako
 
Hello Korimako,

If you wish to remove the Desktop Background option in the Personalization window, then you could METHOD TWO (Step One) in the tutorial for how to add ActiveDesktop to do so.

Hope this helps,
Shawn
 
I hope someone can help me? :)

I had a problem where I couldn't set a background image, but now I can by right clicking the image and setting it as a background. I want to get my Desktop Background options back in the Personalize menu because it disappeared. Can someone help? I'd really appreciate it, thanks in advanced!
 
Hello Slchhouk, and welcome to Vista Forums.

Did you already try step one in METHOD TWO to see if it can restore that option in the Personalize menu?

Shawn
 
yea, i did thanks. haha i just realized that after the changes i should have restarted my laptop. and then it appeared back again :D lol thanks.
 
I downloaded
To Show the Desktop Background Option -

To Remove the Desktop Background Option -

To Enable Changing the Wallpaper -

and it no longer tells me to contact administrator when i click on change desktop Background, which is great, but my dackground wont change. it just stays black. i even tried right-clicking an image to set, but still nothing.

under "regedit" the only thing in my "Active Desktop" folder is that "(Defult) REG_SZ" file

What did i do wrong? Was i supose to download all the reg files. I was just affraid it wud get rid of my options to change desktop like the desciptions said.
 
Hello Djtzan, and welcome to Vista Forums.

Is your Vista activated?

If it is, then also check in Make the computer easier to see in the Ease of Access Center in the Control Panel (Classic View). Make sure that the Remove background images option is unchecked.

EAC.jpg

Hope this helps,
Shawn
 
OMG! I totally 4Got I did that! I was seriously about to completely restore my Laptop lol Thank You. But sence i did a system recovery, I no longer have the option to set the wallpaper from control panel. It says once again "Disabled, please contact system administrator" So I went aheah an ran the "Enable changing wallpaper", restarted it twice, but still no change. Please Help
 
Djtzan,

I have updated the "Enable_Changing_Wallpaper.reg" download in the tutorial to include another location. Please try it to see if it may work for you better now.
 
Sorry, but it didn't it still says "Disabled, please contact system administrator" I wish i knew wat i did last time that wrked
 
Top