Folder Window Icon Text - Hide or Show File Names

ByLine
How to Hide or Show File Names in Vista
Synopsis
This will show you how to hide or show all file and subfolder icon names (text) in only the currently opened folder in a Windows Explorer window.
How to Hide or Show File Names in Vista

information   Information
This will show you how to hide or show all file and subfolder icon names (text) in only the currently opened folder in a Windows Explorer window. By default, they are set to show file names.

This can be handy if the folder contains nothing but images or videos, you may only want to have thumbnails showing without text.
warning   Warning
You can only set to hide or show icon file names from within the Pictures and Video folder template first. After you hide or show the file names in this template, you can then change the folder template back to what ever one you want and the icon file names will remain the same way you set them in the Pictures and Video folder template.

EXAMPLE A: File and Folder Names set to Hide
Hide.jpg
EXAMPLE B: File and Folder Names set to Show
Show.jpg




OPTION ONE
To Hide the File Names

NOTE: Even with the file names set to hide, you can still see the file names in the Details pane when you just highlight a file or do OPTION TWO below.
1. Open the folder in Windows Explorer that you want to hide all file names in. (See Example B screenshot above)​
2. If not already, temporarily change the folder template to Pictures and Video first.​
NOTE: Make note of what your current folder template is for this folder. so that you can change it back to in step 5.​
3. Right click on a empty area in the folder window and click on View, then click on Hide File Names to check it. (See left screenshot below)​
NOTE: If Hide File Names is grayed out, then make sure that you have either Extra Large Icons, Large Icons, Medium Icons, or Small Icons selected (dotted) instead of List, Details, or Tiles first. (See right screenshot below)​
Right_Click.jpg Grayed_Out.jpg

4. The file and folder names should now be gone. (See Example A screenshot above)​
5. If you changed the folder template in step 2, then change it back to the folder template that you want or had before.​
6. Your done.​




OPTION TWO
To Show the File Names again Temporarily

NOTE: This is if you have the file names set to hide in OPTION ONE above. It will not matter what folder template you are using for the opened folder window for this option.
1. Open the folder in Windows Explorer that you want to temporarily show all file names in. (See Example A screenshot above)​
2. Right click on a empty area in the window and click on View, then click on either List, Details, or Tiles to dot one of them. (See screenshot below)​
NOTE: Hide File Names will be grayed out until you select (dot) either Extra Large Icons, Large Icons, Medium Icons, or Small Icons again.​
Right_Click.jpg

3. Your folder window will now look similar to this. (See screenshot below)​
NOTE: When you select (dot) either Extra Large Icons, Large Icons, Medium Icons, or Small Icons again, then the file names will be hidden again.​
Details.jpg





OPTION THREE
To Show the File Names

NOTE: If you had the file names set to hide in OPTION ONE, then this will show you how to have them show all the time again.
1. Open the folder in Windows Explorer that you want to hide all file names in. (See Example A screenshot above)​
2. If not already, temporarily change the folder template to Pictures and Video first.​
NOTE: Make note of what your current folder template is for this folder. so that you can change it back to in step 5.​
3. Right click on a empty area in the window and click on View, then click on Hide File Names to uncheck it. (See left screenshot below)​
NOTE: If Hide File Names is grayed out, then make sure that you have either Extra Large Icons, Large Icons, Medium Icons, or Small Icons dotted instead of List, Details, or Tiles first. (See right screenshot below)​
Right_Click.jpg Grayed_Out.jpg

4. The file and folder names should now be back. (See Example B screenshot above)​
5. If you changed the folder template in step 2, then change it back to the folder template that you want or had before.​
6. Your done.​
That's it,
Shawn



 
Last edited by a moderator:
Shawn Brink

Comments

When I show the file name in the Vista windows, only a partial part of the file name shows up, unless I have the cursor over the file name and then the complete filename will appear over that one file name. Is there any way to set the folder options so complete file names appears all of the time on all of the files?
Thanks for your time,
Ed
 
Hello Ed,

This is due to the file name being longer than the icon's vertical and horizontal spacing will allow for. You can adjust the Icon Spacing sizes in the Advanced Appearance settings (step 6) until the fill name is fully displayed.

Hope this helps,
Shawn
 
The vertical and horizontal resizing took care of my problem! The interesting thing was that at first it did not appear to have worked as the icon names were still truncated. But I then noticed that once I hovered the cursor over the truncated name to see the full name, the full name then remained.
Much appreciated!
Ed
 
Hello Ed,

Interesting. I'm happy to hear that you got it sorted. The window may have needed to have been refreshed (F5) for the names to show again.
 
The folders in my Music folder used to display the names underneath them, but now they won't. I have followed your tutorial for displaying the file names but when I go to View, there is not an option for "Hide file names" like there is in the Pictures folder. Why is this an option for hiding in the Pictures folder and not the Music folder? How can I get the names to display underneath when I'm viewing them in the Large Icon. When I view them in the Tiles setting, the names are there, but not in the Large Icon setting?

Thanks,
Carolyn
 
Hello Carolyn, and welcome to Vista Forums.

Under OPTION TWO, you will need to do step 2 first to change the folder template of the C:\Users\(user name)\Music folder. Afterwards, you should be able to see the "Hide file names".

Hope this helps,
Shawn
 
Hi Shawn,

No, it doesn't work. I have followed every step and the "Hide file names" option is NOT there. I wish I could show you what mine looks like but I don't know how. The "Hide file names" is only an option in the Pictures folder.


Thanks for helping me with this. I have spent HOURS trying to figure out why my file names are no longer on my music folders. Like I said before, the option to "hide file names" is simply not there on my music folder. I do what you say in step 2 of option 2 and this is what I have:

Extra Large Icons
Large Icons
Medium Icons
Small Icons
List
Details
Tiles
Auto Arrange
Align to Grid

There's no "Hide File Names" which should be just above "Auto Arrange".

I can't for the life of me figure out what happened! I guess I will just have to live with the fact that I can only use the Tiles in order to see the file names.

Thanks for your help, though.

Carolyn
 
Last edited by a moderator:
Carolyn,

Check to make sure that you are doing this from the C:\Users\(user name)\Music folder location and not from the Start menu location instead.

You will need to temporarily change the folder template of the C:\Users\(user name)\Music folder to be Pictures and Video instead of Music Details.

You should then see the View - Hide File Names to click on it to uncheck it.

Afterwards, change the folder template back to Music Details.


If you still cannot change it in the Music folder, then check with OPTION THREE in the tutorial below to make sure that the Music folder is set with it's default location in the registry. The download will be the easiest way to make sure.

http://www.vistax64.com/tutorials/148461-personal-user-folder-restore-missing-folder.html

Hope this helps. :)
 
You will need to temporarily change the folder template of the C:\Users\(user name)\Music folder to be Pictures and Video instead of Music Details.

You should then see the View - Hide File Names to click on it to uncheck it.

Afterwards, change the folder template back to Music Details.
Thank you so much! It worked! I wasn't temporarily changing the folder template to be Pictures and Video instead of Music Details and then changing it back to Music Details once I had unchecked the Hide File Names. When I did this, IT WORKED! Boy, I spent hours and hours trying to figure this out before finally finding this forum.

Thanks so much!

Carolyn:D
 
Shawn, for some reason all my desktop icon labels are hidden. Unlike you, I want them back!

I can't follow the instructions here to restore them. Step 2 says to change the Folder Type Template, and to do that I have to go into the Properties of the Desktop folder and click the Customize tab. Unfortunately, there is no Customize tab for the Desktop folder.

I read your other tutorial, "Desktop Icon Text - Hide or Show". I know that's only to hide or restore labels one at a time, but I tried it anyway. It didn't work.

Can you help? Thanks.

-- ShawnVW
 
Hello Shawn, and welcome to Vista Forums.

Yeah, the Desktop folder is a bit harder to do this with, but this should get it for you:

Change the folder template from within the C:\Users\(user-name) folder to Pictures and Videos with the ...apply to all subfolders... option checked.
Properties.jpg
Now check to see if Hide File Names is unchecked in the C:\Users\(user-name)\Desktop folder.
Desktop.jpg
Afterwards, change the folder template back to All Items for the C:\Users\(user-name) folder and subfolders.

Hope this helps,
Shawn
 
I tried it, Shawn, but it turns out the Hide File Names was already unchecked. I tried checking it, then unchecking it, but nothing changed.

-- Shawn
 
Hey, Shawn

I didn't do anything to hide the icon names. They were visible when I was using Vista, but disappeared when I upgraded to Windows 7. I tried the method you mention here (Option 2, Method 1), to see if I could restore them one by one, but it didn't work.

If not, then you might see if doing a system restore using a restore point dated before this happened may be able to fix it for you.
I don't have any System Restore points. Remember, this happened as soon as I upgraded to Windows 7, so any Restore points from Vista must have been wiped out.

-- Shawn
 
Oh, Windows 7 should be discussed at our sister site Seven Forums instead to keep this one on topic. ;)

It sounds like it got corrupted during the upgrade. You can try a repair install to see if that may help. If not, you may need to do a clean install of Windows 7.
 
hello how r u?

my all file hide his name & i don't how to return this name to foldar
i'm do the planing to back name but i don't have icon on view hide file name :sarc: :confused::confused::confused::confused:
i need help from u & all
 
Hello Ibrahim, and welcome to Visat Forums.

I'm not quite sure of what you mean. It appears that English may not be your native language, but that is ok. If you need a bit of help with translation, I find that Google Translate is great for this.

Could you also post a screenshot of this?

If you do not mind resetting all of your folder view settings back to default, then using the download in Option One of Method Two will be able to restore this as well.

http://www.vistax64.com/tutorials/70819-windows-explorer-folder-view-settings.html

Hope this helps fro now,
Shawn
 
Top