.Net Framework updates not installing

xRingox

Member
Im trying to update .Net Framework 3.5 security update and .NET Framework 4 client profile for windows vista Home Premium SP2. I keep getting a failure to install updates and this is the error message I get:
Windows Update_000000FF, that one is for the security update, and this one is for the .4 version of Framework: Windows Update_00000001. Now I've been all-over the forums and a lot of people have this problem. But their is no answer for it, I need a fix!!!
Operating system:
AMD Phenom X4, Quad Core 9150e processor, 4gb Ram, 500gb Harddrive, A Nvidia Geforce GTX Galaxy 220 video card. Please reply to by this thread or email at [email protected]:mad:
 

xRingox

Member
Re: .Net Framwork updates not installing

I downloaded the All supported x64 based versions of windows vista, and ran it and I got a error
Installer encountered and error: 0x80040154
Class not registered
I ran the msinfo32 thing to make sure what version I had.
System info:
Microsoft windows vista Home Premium
Version: 6.0.6002 service pack 2 build 6002
system type: x64 based Pc
Did I download the wrong version, I will wait for your reply before I try another download. Thank you
 

niemiro

Banned
Re: .Net Framwork updates not installing

I downloaded the All supported x64 based versions of windows vista, and ran it and I got a error
Installer encountered and error: 0x80040154
Class not registered
I ran the msinfo32 thing to make sure what version I had.
System info:
Microsoft windows vista Home Premium
Version: 6.0.6002 service pack 2 build 6002
system type: x64 based Pc
Did I download the wrong version, I will wait for your reply before I try another download. Thank you

Hmmm. It has gone wrong! This is not your fault. It is to do with your Windows Update issue. It is just difficult to fix something without the tools to fix it! However, there are things we can try.

Please follow STEP ONE only here: Troubleshooting with System Update readiness Tool - Windows 7 Forums

Then run this tool: Repair & Fix Windows Updates with Fix WU Utility | The Windows Club

Then try the install again, and report back.

Thanks, and good luck!

Richard
 

xRingox

Member
Re: .Net Framwork updates not installing

I have a question. How do you take those pics of folders I see everyone always doing, so I can show it on this thread? Might even be more helpful. And also before I continue when I delete those folders should I delete the entire folder or just whats in the folder?
I know I am being annoying, I just do not want to cause a another problem.
 

niemiro

Banned
Re: .Net Framwork updates not installing

I have a question. How do you take those pics of folders I see everyone always doing, so I can show it on this thread? Might even be more helpful. And also before I continue when I delete those folders should I delete the entire folder or just whats in the folder?
I know I am being annoying, I just do not want to cause a another problem.

You are not being annoying at all! Sometimes we get carried away. Slow us down and ask questions whenever you feel the need to. You can learn how to use the Windows Vista Snipping Tool here: Capture a Screen Shot with the Snipping Tool in Windows Vista and Windows 7

If you take a screenshot of the inside of each of those folder, we should be able to work out which one you should delete. However, they are all temporary files, and in theory at least, no harm will come from emptying them.
 

xRingox

Member
Re: .Net Framwork updates not installing

file:///C:/Users/JOHNWH%7E1/AppData/Local/Temp/moz-screenshot-6.pngfile:///C:/Users/JOHNWH%7E1/AppData/Local/Temp/moz-screenshot-7.pngfile:///C:/Users/JOHNWH%7E1/AppData/Local/Temp/moz-screenshot-8.pngfile:///C:/Users/JOHNWH%7E1/AppData/Local/Temp/moz-screenshot-9.pngRingo.JPG
This is from the file folder c:\windows\checksur\v1.0
Should I just delete the 1.0 folder. If that is the case I will be able to do the rest without further questions. At least on this subject. Thank you for being patient
 

xRingox

Member
I followed all the steps on step 1, then ran the utility program at first it gave me a error, but told to skip it and continue. It said it completed successfully, but then I double checked and found some of those files I did not delete. I deleted them and once again I ran the utility. It did not give me a error, then it said it completed successfully.
I then attempted to install the updates again, it gave me the exact same errors. Should I have ran the first program you gave me after I ran the utility?
Thanx, Ringo
 

niemiro

Banned
I followed all the steps on step 1, then ran the utility program at first it gave me a error, but told to skip it and continue. It said it completed successfully, but then I double checked and found some of those files I did not delete. I deleted them and once again I ran the utility. It did not give me a error, then it said it completed successfully.
I then attempted to install the updates again, it gave me the exact same errors. Should I have ran the first program you gave me after I ran the utility?
Thanx, Ringo

That is excellent news! While we appear to have got nowhere, we have got very far. That utility tells me what is corrupted and needs fixing. I fix it, and Windows Updates work again. Now I need the log.

Please navigate to C:\Windows\Logs\CBS\ and copy BOTH CheckSUR.log and CheckSUR.log.persist to your Desktop.

Then upload them here.

If you cannot upload them, copy and paste them between code tags.

Thanks!

Richard
 

xRingox

Member
I ran Chkdsk and it did its thing, ran for quite a while. It finished, said it repaired things, so I tried to run the updates again and the same thing happened, failed with the exact same errors.
 

xRingox

Member
Hey Richard I noticed a little bit ago the updates installed on their own, except the .Net Framework 4. That one still failed but the other security update did install. That's odd isn't it? Why would they not install for so long then some install, its just funny. What do you think.
 

niemiro

Banned
Sorry about the late reply. Can you please number any KBs not installing. Remember that if one fails, the whole group fails, so please try them individually, and that may explain why some worked, if put through in a different group.
 

xRingox

Member
I have no idea. And I have tried them individually. Like I leave my system to do it auto. Last night around 3:00am it just installed and on ly the one failed. .Net Framework 4.
And also Richard what did you mean by Router, you mean my box that plugs into my computer right?
I just tried to install it again and it gives me this error WindowsUpdate_000000FF. Then it says a problem has caused HOTIRON HOTFIX installer to stop working.
 

Attachments

  • Capture.JPG
    Capture.JPG
    16.4 KB · Views: 17

xRingox

Member
Ah, I don't mean to be rude and you are probably a busy person but. Do you have anymore suggestions for me to try. I mean I would like to keep trying.
 
Top