New Folder

ByLine
How to Fix the New Folder Context Menu Item in Vista
Synopsis
If when you right click on the desktop or in a User folder and click on New and Folder it does not work, then this will show you how to fix the Folder menu item so it will create a new folder again.
How to Fix the New Folder Context Menu Item in Vista


information   Information
If when you right click on the desktop or in a User folder and click on New and Folder it does not work, then this will show you how to fix the Folder menu item so it will create a new folder again.
Tip   Tip


EXAMPLE: New Folder in the Context Menu and a New Folder
NOTE:
You see this context menu only when you right click on a empty space on the desktop and in a nonsystem folder (Ex: C:\Users) Windows Explorer window. If you right on a empty space in a system folder (Ex: C:\Program Files, C:\Windows, etc...} Windows Explorer window, you will only see Folder in the New menu.

New.jpg New_Folder.jpg
EXAMPLE: New Folder in the Organize Toolbar Button
NOTE:
This is the Organize toolbar button in Windows Explorer.

Organize.jpg
EXAMPLE: New Folder in the File Menu
NOTE:
This in the Windows Explorer Menu bar. It is not availale in the Computer window though.

File_Menu.jpg


Here's How:
1. Click on the download button below to download the NewFolderFix.reg file.​
download

2. Right click on the downloaded NewFolderFix.reg file and click on Merge to add it to your registry.​
3. Click on the Run button in the Security Warning prompt.​
4. Click on Continue in the UAC prompt.​
5. Click on Yes in the confirmation prompt.​
6. Click on OK in the success prompt.​
7. Log off and log on, or restart the computer to apply the fix.​
8. When done, you can delete the NewFolderFix.reg on the desktop if you would like to.​
NOTE: If the problem still persists, then do a System Restore using a restore point dated before the problem.
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

hey ..

i have download newfolderfix.reg but it is saved as newfolderfix.download .. please help me with it .. i dunt knw how to run this file .. as vista on my pc does not knw how to open it. and please also explain how to merge it with registery .. thanks
Hello Sobia, and welcome to Vista Forums.

See if you can rename the file name to change the file extenion to .reg instead of .download. If you can, then you should be able to merge it afterwards. If not, then I put in a ZIP file below to see if you are able to extract and use it instead.


Hope this helps,
Shawn
 

Attachments

thanks .

I have merged this file with the registery but problem/error is still there ..

what should do i now ?

i also have disabled offline files ..
 
Sobia,

As a test, create a new administrator account and see if it works properly in it. If it does, then copy the contents of the old user account's C:\Users\(user-name) folders into the new account's corresponding C:\Users\(user-name) folders to keep your settings.
 
Thank you for this post! However, after I clicked the "Run" option, the file was opened with Notepad, with a lot of MS-DOS-looking gibberish. There was no other option to continue. What should I do now?
 
Hello Mario, and welcome to Vista Forums.

It sounds like your .reg associations have been set to open with Notepad by mistake. In Default Programs, check to make sure that the .reg file extension has it's "Current Default" set as Registry Editor (C:\Windows\regedit.exe).

Afterwards, merge the .reg download in this tutorial here again to see if it can fix your New Folder. :)

Hope this helps,
Shawn
 
I have a brand new computer and am having this issue. I have tried to download a couple of the reg fixes, the new folder one and the 64 bit one that allows you to rename the new folder and the computer downloads the file and it appears for a second and instantly disappears. I can not find the setting in my anti virus, firewall, or windows defender that is causing this. I have even changed the .reg extension and tried to download onto a dvd drive. What the heck is going on?
 
Hello Mauiiufan, and welcome to Vista Forums.

Could you explain your problem with more detail? I'm not sure of what you mean. If you mean the the download disappears, then click on "Save" and save it to the desktop when you download it, or try the reg in a ZIP download a few posts above this one.
 
I choose a place to download it..desktop, my download folder, even a DVD drive....The file downloads and you see it move from the temp folder to wherever you chose to download it to and you see it for a second and then it disappears, like the computer thinks its a virus and deletes it immediately. I have never seen anything like it.
 
I placed in a ZIP file to download below instead. Sometimes a .reg file will be filtered by some security programs when downloading.

download
 
Same thing. Appears to download. I see it move from the temp folder to where I place it and it disappears. I am waiting on a call from Toshiba. This is rediculous.
 
Muaiiufan,

As a test, temporarily disable your antivirus or other security programs to see if it they are interfering with the download. Where are you trying to save the file to?
 
I had already done that. No good. When the antivirus was turned on I had excluded scanning from the 3 different folders I was trying to save to. Excluded exe and zip files. Same result. I think something is wrong in the registry related to why I can not rename a new folder.
 
As another test, create a new administrator account to see if it works in that account. If so, then you can just copy of any user files that you want to keep. After everything checks out ok for a day or so to be sure, you can delete the old account from within the new one.
 
Well there had to have been some kind of windows update that fixed my ability to save the files cuz I can do that now. Installed both of the reg files (newfolderfix and fix rename 64 bit vista) and I still cant rename. This issue is all over the internet. 296,000 hits for can't rename folder in vista and some things work for some. Some do not.
 
Yep I know but after it didnt fix the problem I wanted to see what was being put into the registry and if you click edit you can see that. Nothing was there.
 
Top