Personal User Shell Folders

How to Fix a Personal User Shell Folder Displayed as a Standard Yellow Folder Icon in Vista
If you open your personal user folder in the Start menu and the folder is displayed with a standard yellow folder icon instead of the special green folder icon, then this will show you how to fix it.
How to Fix a Personal User Shell Folder Displayed as a Standard Yellow Folder Icon in Vista

information   Information
If you open your personal user folder in the Start menu or from C:\Users\(user name), and a user folder has a standard yellow folder icon instead of the special green folder icon, then this will show you how to restore the green folder icon for that particular user folder.
Note   Note
This usually can occur when the desktop.ini file in the shell folder is missing or incorrect, or the user folder has no read only attribute set to it.

EXAMPLE: Special Green Personal User Profile Folder Icons

For the User Name Folder

NOTE: This is the User Name folder that appears in the Desktop folder tree view in Windows Explorer or the Start Menu.
1. Right click on a empty area of the desktop and click on Personalize.​
2. Click on Change desktop icons in the upper left corner. (See screenshot below)​

3. In the lower box, click on your User Name folder to highlight it in blue. (See screenshot below)​

4. Click on the Restore Default button. (See screenshot above)​
A) Click on Apply.​
NOTE: If it did not restore the default User Name folder icon, then proceed to step 5.​
B) Go to step 6.​

5. Click on the Change Icon button. (See screenshot below step 3)​
A) If not already in the top line, then click on the Browse button and browse to C:\Windows\system32\imageres.dll.​
B) Select the default User Name folder icon and click OK. (See highlighted in blue icon in the screenshot below)​

6. Click on OK. (See screenshot below step 3)​

For the User Folders in the User Name Folder

1. Verify that the user folder has it's correct default path in METHOD THREE here.​
Shell Command
2. Open the Start Menu.​
3. Type in the Shell command (see table below) for the Personal User folder and press Enter..​

User Folder

Shell Command














shell:My Music


shell:My Pictures

Saved Games





shell:My Video

4. This will open the personal user folder from it's location.​
5. Close the personal user folder window.​
6. Check to see if the personal user folder has turned back to the special green folder in the start menu.​
A) If yes, then your done.​
B) If not, proceed to STEP TWO below.​

Replace Desktop.ini File for User Folder
7. Have Show hidden files and folders dotted and Hide protected operating system files (Recommended) unchecked in Folder Options.​
NOTE: For how, see OPTION TWO here:How to Hide or Show Hidden Files and Folders in Vista
8. Click on the download button below to download the User file, then click on Save and save it to the Desktop.​

9. Right click on the User file (on Desktop) and click on Open.​
10. Extract the same folder(s) for your user folder name with the standard yellow icon displayed to the Desktop.​
11. Open the extracted folder and right click on the desktop.ini file and click Copy. (See screenshot below)​
NOTE: This file is set as a hidden file. This is why it is faded.

12. Open the user folder that has the standard yellow folder icon displayed.​
A) Right click on a empty area in the folder's window and click Paste.​
NOTE: If you are asked if you want to replace the old desktop.ini file, then click Copy and Replace. (See screenshot below)
B) Repeat step 11 for each user folder you need to fix.​

13. Close all windows.​
15. If prompted, click on Continue in the UAC prompt.​
16. In the elevated command prompt, type the command below (see table below) for the user folder name you need to fix. (See screenshot below table)​
NOTE: This will set the user folder as Read-only. You can Copy and Paste these to make it easier for you.
WARNING: If you have changed the default location of your user folder, then you will need to type the full path of it's new location after attrib +r instead of the default %USERPROFILE% location below. For example, attrib +r D:\New location

User Folder



attrib +r -s -h %USERPROFILE%\Contacts /S /D


attrib +r -s -h %USERPROFILE%\Desktop /S /D


attrib +r -s -h %USERPROFILE%\Documents /S /D


attrib +r -s -h %USERPROFILE%\Downloads /S /D


attrib +r -s -h %USERPROFILE%\Favorites /S /D


attrib +r -s -h %USERPROFILE%\Links /S /D


attrib +r -s -h %USERPROFILE%\Music /S /D


attrib +r -s -h %USERPROFILE%\Pictures /S /D

Saved Games

attrib +r -s -h %USERPROFILE%\"Saved Games" /S /D


attrib +r -s -h %USERPROFILE%\Searches /S /D


attrib +r -s -h %USERPROFILE%\Videos /S /D


17. Repeat step 16 for each user folder that you replaced the desktop.ini file for.​
18. Close the elevated command prompt.​
19. Restart the computer, or logoff and login again for the changes to take effect.​
20. Confirm that the folder icon is back to normal.​
21. You can now delete the downloaded folders on the desktop and set your hidden files and folders settings back to normal in step 7 above.​

That's it,



  • User
    3.1 KB · Views: 15,702
  • thumb_Username_Folder.jpg
    2.6 KB · Views: 43
Last edited:


Staff member
Your welcome Zhang. I'm happy to hear that you got it sorted out. Thank you for letting us know that it was your Free Download Manager that was the cause of download problem.



New Member
Hi there I am having the same problem as Flexo where its not the icons in the user folder its the actual user folder icon itself and I've tried the suggested ways to fix it but it is still showing up as a standard yellow folder. Hope you can help me...



Staff member
Hi Zorro, and welcome to Vista Forums.

Try using the attrib command attrib +r %USERPROFILE% in step 9 under STEP TWO in this tutorial, but this time in a elevated command prompt and restart the computer afterwards. The tutorial has been updated for this.

If this still does not help, then see if rebuilding the icon cache may.

Hope this helps,


New Member
There is nothing wrong with my icons they are the normal green vista icons, I have made a new folder for Vuze downloads, and I have managed to change the folder to the green vista folder, However its the green username folder i want but can not find, I want the green icon like the one you find on your desktop, not the plain green one. Can you help? Please :)


New Member
Thanks for your help brink but it still didn't work.
I have solved it now and I can't believe how I didn't think of it, I'm kicking myself that I didn't try this already as it was so simple.
What I did was right clicked the desktop > Personalize > Tasks (on the left of the window) > Change desktop Icons
Click on your User Folder (What ever you've named it) > Change Icon...
Navigate to C:\Windows\system32\imageres.dll
Find the default icon (Top row 30th across for me) and that did it!
Thanks for your help with the other folders!


Staff member

I guess we were both try to make it harder than it was. LOL, it should have been so obvious. :o

Thank you for posting back your solution. I have updated the tutorial to include it.



New Member
i am new in this forum, I'm looking fix my pictures shell folder and i did it with this help, thanks very much for your help


New Member
Hey, I've been having a problem with my icons steadily becoming normal yellow folders. At first I just lived with it, but today I noticed that almost all of them had become yellow. I'd searched the net for a guide to help before, but couldn't find anything that helped. I searched long and hard today to solve this problem and ended up here.

Long story short, your guide helped me out and I have my pretty icons again :D lol.
Thanks alot, and hope you continue to write more great tutorials and tips in the future



I just installed Vista Ultimate x64 (upgrade from Vista Home Premium x86) and this bug hit me. I tried using Winbubble and a bunch of other useless applications to fix the issue, but my Contacts, Links, and Saved Games folders refused to be repaired... This method worked perfectly.

Although, using the command "attrib +r %USERPROFILE%\Saved Games" did not work, it kept on returning an invalid parameter error... I figured it was because of the space. Using this fixed it:
attrib +r %USERPROFILE%\"Saved Games"

Thanks again.


Staff member
You're welcome Ramzy. Thank you for the correction for the Saved Games command. It has been updated in the tutorial so others will not have problems with it.



Just one quick note you might like to add, if the directory has been moved to another drive by the user they will need to type the full filepath in after the attrib +r. Hope this helps, Marcus.


Power User
Hey Brink! Thanks to your tutorial, I recovered my "Music" and "Pictures" folder icons.

Reading through all the 6 pages, I have noticed that no matter how hard we try, those exclusive icons eventually are replaced by normal folder icons.

Isn't there a way to lock the icons to the respective folders? It seems pretty tiring to go through the entire process.
What mystifies me more is why the icons are replaced by normal icons in the first place?

Thanks again!


Staff member
You're welcome Dragor,

I'm happy to hear that you got the correct folders back for those.

It can switch to a yellow folder if something went wrong while changing their default locations. Usually it will be the desktop.ini file that gets corrupted or missing, and the filder loses it's read only status.



New Member
Hi Brink,

Thanks for the tutorial! One problem I had for a while is that while I extracted the folders from the zip file, they weren't getting copied correctly because I already had desktop.ini in my windows temp folder. It was prompting me to replace the file but I neglected to do so because it wasn't obvious to me which file it wanted to overwrite. It wasn't until I saw that it was a temp file that I actually replaced it, and then everything sorted out nicely.