Shutdown

ByLine
How to Speed Up Shut Down in Vista
Synopsis
This will show you how to set the amount of time Vista waits for programs to save data and close before shutting down. Decreasing this time will speed up the shutdown process.
How to Speed Up Shut Down in Vista

information   Information
This will show you how to set the amount of time Vista waits for programs to save data and close before shutting down. Always, as usual, make sure you save and close applications before shutting down to prevent data loss.
Tip   Tip
When you shut down the operating system, the OnShutdown method is called. However, the OnShutdown method does not change the system state to the Stop state. This behavior causes the service to appear unresponsive. Therefore, the shutdown process is delayed. If you have this problem, see: Microsoft Help and Support: KB943412 Hotfix . Be sure to download the correct 32 bit (x86) or 64 bit (x64) version. To see what bit version you have of Vista, open the Control Panel (Classic View) and click the System icon, or right click Computer in the Start Menu and click Properties. You will see the bit version under the System type section.
warning   Warning
You should always save and close all programs before shutting down the computer to help prevent any data loss.





METHOD ONE
Using a REG File Download

1. To Speed Up Shut Down Time
A) Click on the download button below to download the file below.​
NOTE: This uses the 2 seconds (2000) setting. If you want shutdown to wait for a different amount of seconds, then do the manual method below.
2_Second_Shutdown.reg
download

B) Go to step 3.​

2. To Restore Default Shut Down Time
A) Click on the download button below to download the file below.​
NOTE: The default time is 20 seconds (20000).
Default_Shutdown.reg
download

3. Click on Save, and save the .reg file to the Desktop.​
4. Right click on the downloaded .reg file and click Merge.​
5. Click on Run, Continue (UAC), Yes, and then OK when prompted.​
6. When done, you can delete the downloaded .reg file if you like.​




METHOD TWO
Manually in Registry Editor

1. Open the Start Menu.​
2. In the white line (Start Search) area, type regedit and press Enter.​
3. If prompted by UAC, then click on Continue.​
4. In regedit, navigate to the location below. (See screenshot below)​
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

5. In right pane, right click on WaitToKillServiceTimeout and click Modify.​
Reg.jpg

6. Type in a number between 2000-20000 (2-20 seconds) and click OK. (See screenshot below)​
NOTE: The default time is 20000. I use 2000 and have not had any problems. Your experience may vary.
Modify.jpg

7. Close regedit.​
NOTE: If you have problems with your computer shutting down to quickly with the value you set in step 6, then repeat step 6 above to increase the time until Vista does shutdown properly.
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

Hello Danielson,

Do you have anything running when shutting down the computer? You can check in Task Manager to see what is running before you shutdown.

Did you already do this tutorial? Did it help any at all?

In the mean time, you can use this shutdown shortcut that forces an instant shutdown until you find what program is causing the hang-up at shutdown.

Hope this helps for now,
Shawn
Hi Brink excellent forum glad i found it,

Yes i have done the full tutorial this will be my second go threw it as i have just had to reinstal vista ultimate "trojan" not related to any guides or links on this forum.

I got reboot time down to 64sec from 108sec was very impressed.

Heres what i see using task manager all apps are closed before shut down, does this help:



Using the shortcut seems to take me out off windows quick but im left with black screen saying "shutting down" for 3 mins +, this never happened before the reinstal "64 sec reboot using the same guide" so i wonder whats wrong, maybe will be easier/faster to reinstall again.
 
Last edited:
Dan it could be a number of things that is causing the shutdown hangup. The only true way to really find out what is causing it is to close each non Vista system program listed there one at a time, then shutdown to see if it does so like it should. For example, uTorrent.exe, Opera.exe, SmoothView.exe, etc.....
 
Hello Dinesh,

With those values, Vista may try to shutdown to quickly not allowing time for everything to shutdown properly and cause a delay (hang) for a bit at shutdown. You can try to see if it works ok for you or not. If not, then you can just increase the value until it does. :)
 
I will try to change the value to 2000, 200 and 20 and will see the reboot time and the one with less reboot time will be prefered.
But i have noticed that when we change the waittokill value in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control, it will also change the value in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet001\Control but it wont change in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet002\Control.
Any specific reason?
I do not know how to explain but I hope i m able to put across my message to you.
 
Dinesh,

CurrentControlSet is your current one being used by Vista.

CurrentControlSet001 is the most recent backup of CurrentControlSet.

CurrentControlSet002 is the older backup of CurrentControlSet.

You would only want to make changes in the CurrentControlSet location to affectively make the changes in Vista. ;)

Hope this helps,
Shawn
 
Got it.
I set the value of CurrentControlSet as 2000 and shutdown time was 65 secs and when i changed it to 200, it was 64 secs. but when i changed it to 20, shutdown time was increased to 67 secs. so i m keeping it to 200.
Note: In Windows 7, the default waittokill value is 12000 and it shuts down the system real quick if set to 120.
 
Yeah, that Windows 7 is better at this. I'll take note of that time value for it.

Thank you,
Shawn
 
Hello,

I have Vista Home Premium 64-bit.

When I attempt to apply this tweak, after restart it resets itself back to 20000 ms.

Any idea why? I have Admin Privileges.

Despite it resetting itself to the default however, i find the system shuts down quite quickly, well within 15 seconds.

Thanks

Corey

Also, I noticed I have 5 of the Control Sets, plus the Current control set.

The only entries in ControlSet002 and 3 are Control>Session Manager>(default)

Why 5?

Thanks :)
 
Hello Corey, and welcome to Vista Forums.

The CurrentControlSet without numbers is the one currently being used by Vista. The ones with numbers are backups.

Not sure why it would be resetting on unless one of the backups is overwritting it. As a test, change the value using METHOD TWO in all of the CurrentControlSet locations.

Hope this helps,
Shawn
 
Hi Shawn.

I actually attempted that shortly after posting last night.

I'm finding that the tweak will work for two or three restarts, then reset itself back to 20000.

I also tried deleting the 002 and 003 control sets, and after 1 or two restarts, they came back.

All my other registry tweaks that i've applied from this site work no problems. So i don't get why this one keeps resetting.

And I realized that the shutdown is infact longer once it resets to 20 seconds. Goes from about 15 sec, to 32.


As a side note: I applied the Prefetch and superfetch tweaks. Set prefetch to bootfiles only, and superfetch to program files only. I found it cut about 10 seconds off the reboot time, and the system seems a bit quicker.

Thanks

Corey
 
Hum,

I'd like to hold off on that one. I have the Vista Glazz program installed, and I think that command will reset those 3 system files.

I did however apply this command about 2 months ago while messing with vista glazz. My desktop failed to start up, and i had to spend a couple days restoring the originals.

So I'd expect the majority of my system files to be okay.

thanks for the help

EDIT: just some more info: I have an Acer Gemstone laptop, and I'm running Spybot S&D teatimer in the background.
 
Update:

I've been messing around with tweaks all day, and have managed to get the system from a 110 second reboot, down to just 65 Edit: now 55 :)

The real show stopper - Norton 360... what a hog. As soon as i disabled the start up of this program... :geek:

So, now I'm running Avast! and the computer starts so much nicer.

I also downloaded CCleaner.

As for the Shutdown tweak. I tried setting it to 100 ms just for the heck of it. This really sped things up, and after the 5th consectutive reboot, the settings are still there :)

Guess it didn't like 2000 or 5000 ms.

Time will tell. But right now my shutdown time is 9 seconds :)

Thanks

Corey
 
Last edited:
You're welcome Corey. I'm happy to hear that you got it down so much from before. Thank you for sharing your results. :)
 
Hiyya Shawn Don't know if anyone else had this but the machine I was optimising had two sets of control - 001 & 003 the latter being the one that contained the shut down regedit.:)
John
 
Last edited:
Top