Solved Switch AHCI TO IDE (Tutorial HowTo) !!!

Roli

Power User
Wow i am truly amazed how many people found this so helpful , and this tutorial was up at some blogs , and at microsoft help/awnser website , i just cannot believe it :P:P , and 3 years passed since ive been here , anyway i will try to find that reg key that i made back then and i hope that i will find it
 

My Computer

System One

  • Manufacturer/Model
    Gateway FX series 7809U
    CPU
    Intel Core 2 Duo P8700 Fsb 1066
    Memory
    4gb ddr3 Fsb 1066
    Graphics Card(s)
    NVIDIA 9800GTX 1024 mb ddr 3 256 bit
    Sound Card
    Conexant Hermosa HD Audio
    Monitor(s) Displays
    Laptop Lcd panel
    Screen Resolution
    1440x900 17" laptop panel
    Hard Drives
    1x SSD Kingsone hyperX 120 GB
    PSU
    9 Cell battery with 7800 MAH
    Internet Speed
    100 mbit/sec (megabit)

Roli

Power User

My Computer

System One

  • Manufacturer/Model
    Gateway FX series 7809U
    CPU
    Intel Core 2 Duo P8700 Fsb 1066
    Memory
    4gb ddr3 Fsb 1066
    Graphics Card(s)
    NVIDIA 9800GTX 1024 mb ddr 3 256 bit
    Sound Card
    Conexant Hermosa HD Audio
    Monitor(s) Displays
    Laptop Lcd panel
    Screen Resolution
    1440x900 17" laptop panel
    Hard Drives
    1x SSD Kingsone hyperX 120 GB
    PSU
    9 Cell battery with 7800 MAH
    Internet Speed
    100 mbit/sec (megabit)

gman1275

New Member
Thank you for this. I was at my wits end and found your tutorial. Thank you works like a charm. Very impressed with your skill.
 

My Computer

System One

  • Manufacturer/Model
    Inspiron/ N5010
    CPU
    M350 2.27 GHz
    Memory
    4GB

Ex_Brit

If you're going through hell, keep going
Vista Guru
Gold Member
Post #44 above...?
 

My Computer

System One

  • Operating System
    Win 7 Ult SP1 + Win 10 Pro all x64
    Manufacturer/Model
    Alienware ALX x58
    CPU
    Intel® Core™ i7-975 Extreme O/C to 4.02 GHz, 8MB Cache
    Motherboard
    Asus® P6T Deluxe V2 X58 LGA1366
    Memory
    24GB Corsair Vengeance DDR3 SDRAM at 1600MHz - 6 x 4096MB
    Graphics Card(s)
    1792 MB NVIDIA® GeForce® GTX 295 Dual Core
    Sound Card
    Onboard Soundmax® High-Definition 7.1 Performance Audio
    Monitor(s) Displays
    Samsung XL2370 HD LED backlit 23" W/S 2ms response time
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 x 500gb SATA II
    1 x 1TB SATA II
    1 external eSATA LaCie 3TB
    (Non-RAID)
    PSU
    Alienware® 1200 Watt Multi-GPU
    Case
    Unique
    Cooling
    4 case fans @ CPU water cooling.
    Internet Speed
    1gb/s up and down

Otoja

New Member
It worked for Windows 8 also! After using your registry commands there was still no msahci, but iastor and iastorAV appeared and I could change theirs values. Now Windows 8 finally loaded.
I don't know what happens, but by night harddrive stopped being detected in AHCI mode. I've only uninstalled Linux and changed other disks partition table from GPT to MBR. After this the HDD with my OS started being not detectable by bios and whole PC hangs in POST.
 

My Computer

Roli

Power User

My Computer

System One

  • Manufacturer/Model
    Gateway FX series 7809U
    CPU
    Intel Core 2 Duo P8700 Fsb 1066
    Memory
    4gb ddr3 Fsb 1066
    Graphics Card(s)
    NVIDIA 9800GTX 1024 mb ddr 3 256 bit
    Sound Card
    Conexant Hermosa HD Audio
    Monitor(s) Displays
    Laptop Lcd panel
    Screen Resolution
    1440x900 17" laptop panel
    Hard Drives
    1x SSD Kingsone hyperX 120 GB
    PSU
    9 Cell battery with 7800 MAH
    Internet Speed
    100 mbit/sec (megabit)

ilikefree

Vista Guru
Gold Member
I want to go the other way and switch to AHCI as I'm told my SSD will be faster that way
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

yyourb0yy

New Member
Thank you Thank you Thank you!!!!! I didn't have HKEY_LOCAL_MACHINE_System_CurrentControlSet_Services_iaStor even after using his download but it still worked. It works in Windows 7!
 

My Computer

dalkeja

New Member
AWESOME! :party: You're an absolute life saver. You saved me a tremendous amount of time from having to reinstall my OS and all my applications. Amazing that I checked with Microsoft and many other so called Microsoft Consultants and they all said - it couldn't be done! I am glad someone out there had the tenacity and intellect to figure this one out. Thanks so much!!!
 

My Computer

Top