Solved Switch AHCI TO IDE (Tutorial HowTo) !!!

thedeejaynl

New Member
This one helped me as well, thanks!

In my case, a few registry items had different values after running the .reg file (Msahci and iaStorV were 4 (!) and PciIde was already 0), but in the end it worked fine anyway :D
 

My Computer

System One

  • Manufacturer/Model
    Samsung R710

slyda

New Member
Thanks for your solution. This worked for me as well on Windows 7 Ultimate x64 (German) on an ASUS M5A97 motherboard. One difference however: I did not have the HKEY_LOCAL_MACHINE/System/Current_ControlSet/Services/iaStor key. So I changed the rest like you said after applying the .reg file and then restarted my system, went to BIOS and changed SATA mode from AHCI to IDE. Saved, restarted and returned to BIOS to set the boot priority now that IDE was activated, and then Windows launched. It installed some drivers in background and my network adapter stopped working. It detected the cable but no internet / ip information returned on ipconfig /all. I restarted computer and then everything was good. Thank you for the tutorial.
 

My Computer

jerlanloresto24

New Member
me too..i just created account to say THANK YOU VERY MUCH...I'm so messed up, I have a lot of PC to clone with no AHCI support..and a lot of tutorials on the internet but didn't work and I come up to conclusion to reformat again..this saves a lot of time.
 

My Computer

daponticelli

New Member
Welcome all , so let me explain I installed Windows 7 With AHCI set from Bios , but after that i wanted to use ide (becose it boots faster) and when i set Ide from Bios , the windows 7 loading screan camed upp and BSOD (Blue screen of death) with an error code 0x0000005B , i tryed the regedit trick by setting in the "HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci" and then in the right pan the START value from 0 i set it to 1 and it supposed to be working but it was a failiure , it still did the Bsod and i was so pissed of , i wanted to make it work ... AND I DID IT !

Here are the pases :
1) I assume u have installed Windows Vista or Windows 7 with AHCI set from BIOS !
2) Download my registry fix (to add the ide keys to regeditor) simply apply the key
3) Now the manually regedit part Go to :

HKEY_LOCAL_MACHINE_System_CurrentControlSet_Services_Msahci
HKEY_LOCAL_MACHINE_System_CurrentControlSet_Services_iaStor
HKEY_LOCAL_MACHINE_System_CurrentControlSet_Services_iaStorV

And in thease three keys in the right pan u will find a key named "START" change at all three (Msahci,iaStor,iaStorV) values from 0 To 1
Now navigate to HKEY_LOCAL_MACHINE_System_CurrentControlSet_Services_PciIde
,then change the start value to "0"

4) Now u are allmost done , restart your computer/laptop , and go to Bios and set from AHCI to IDE !!! , save settings in Bios and restart

5)Windows will be loading , and VOILA !!! NO BSOD !!! , windows Vista/Seven will install new Ide drivers and u will see in windows device manager that you dont have AHCI drivers anymore , u have Ide drivers !
6)It will prompt for another restart , just restart it and u will be happy ;)

Credits goes for ME ! ONLY ME !!!!! , i searched all the internet and i couldn`t find something like this , so i began from literally everything to everything , a LOT OF REBOOTS AND BSOD`s believe me it was a pain in the ass !
But i done it !, now im ussing Windows 7 With ide mode ...
Every article on the internet when i searched it sayd : Change from the Msahci the start key to 1 if u want to make it boot from ide , but no it is much much more !
For some people it works like that , for some people it doesn`t.

I hope u enjoyed my first tutorial here , sorry for my english , im from Romania , post your results please , for more questions feal free to ask me ;)

Have a verry happy nice day !!! :p:p:p:p

Roli - Oradea .
11 years later, it worked for me.

A friend has a PC with propietary software no longer maintained to operate some machines and suddenly the MoBo died. I managed to set up a similar machine, the original PC used SATA as AHCI but the second one uses SATA as IDE (and there were no way to change it in BIOS) and obviously it didn't work. I had to start a MiniPE CD, load the registries offline, do the changes and now it works again like a charm.

Thanks.
 

My Computer

System One

  • Operating System
    Windows 10

DAC324

New Member
Thanks a lot from my side as well. The tutorials about changing the driver back to IDE are apparently all presuming that Windows was already installed in IDE mode some time ago.
As already described in the first post, if you have Windows installed in AHCI mode and want to switch to IDE for some reason (for me it was the repair of a faulty SSD), it is usually NOT enough to change the `Start` value in `HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci` - as even announced by Microsoft themselves!

So, in short, what you will have to do is:
1. Start Windows in AHCI mode as usual
2. Import the REG file attached to the first posting in this thread here
3. Change the `Start` value to `1` in the following keys:
```
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStor
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStorV
```
4. If `HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStor` is missing, no worries. Just ignore that.
5. Change the `Start` value to `0` in the following key:
```
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Pciide
```
6. Exit Registry Editor and shut down the computer.
7. Start the computer, go into BIOS and set the SATA controller mode to IDE
8. Save settings, exit BIOS, and start Windows. It should be in IDE mode now.

If you want to go back to AHCI, there are only these steps required:
1. Change the `Start` value to `0` in the following key:
```
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
```
2. Shutdown the computer
3. Start the computer, go into BIOS and set the SATA controller mode to AHCI
4. Save settings, exit BIOS, and start Windows. It should be in AHCI mode now.
 

My Computer

System One

  • Operating System
    Windows 10, Linux
Top