This file does not have a program associated

GordonHS

Member
I cannot open any links in my Windows Mail since Nov 09. I get the message "This file does not have a program associated with it for performing this action. Create..."
When I choose Defaults for Windows Mail I get under Extension .eml; under Protocol MAIL TO; under Start menu Email link. These are selected by check marks and saved. This does not solve the Problem. I have Vista Home Premium and IE8.
I have printed instruction from the URL Default File Type Associations-Restore-Vista Forums. I wonder if this will correct the problem but I don't know how to proceed with instruction 1. How do I know what file extension type link I should choose and how do I know which one to restore. I believe the URL was provided by Brink and if you see this perhaps you could help me. Any help on this problem would be appreciated. GordonHS
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

GordonHS

Member
Re: This file does not have a rogram

After reading several posts on this problem I decided to follow the instructioins in Default File Type Asssociations-Restore-Vista Forums. I chose .exe and after downloading it to my desktop I was prompted to choose a program to open it. I chose Internet Exporer. My computer went into rapid convulsions flashing glimpses of IE. I was able after a minute or less to shut down the computer. I don't know what program I should have used. Any comments? GordonHS
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

richc46

Vista Guru
Gold Member
Re: This file does not have a rogram

If you can use your computer, an alternative method, to solve this problem is to go to

control panel and uninstall windows mail. It may be shown as such or as Windows Live

Essentials, depending on the actual mail client that you have. This feature can be

accessed in programs, which is listed in the Control Panel.


After you are uninstalled, install another copy, if you so desire. If you do this time

it should be working properly. If it is make a system restore point, and update at least

once a week, so that a problem like this will not happen again. At least if it does you

can restore back to good time.

You must back up your mail and you should make a system restore point before you

begin in the event that this little problem escalates into a bigger one, during the

repair process.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

GordonHS

Member
Re: This file does not have a rogram

Thanks richc. My Progams shows Windows Live Essentials; Windows Live Favorites forWindows Live Toolbar; Windows Live Sign in Assistant; Windows Sync; Windows Live Upload Tool. Should I uninstall only Windows Live Essentials? Where do I find Windows Mail to reinstall? Thanks, GordonHS
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

richc46

Vista Guru
Gold Member
Re: This file does not have a rogram

Uninstall only Window Live Essentials. It contains the email client, and possibly some

other programs such as messenger. When you go to the site you can choose what else

you want to install in addition to Mail

It is my thought that your current email client is corrupt and the download will correct

that situation


Here is the link
Mail - Windows Live
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

richc46

Vista Guru
Gold Member
Re: This file does not have a rogram

In addition, I feel it is wise to make a system restore point before making any changes
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

GordonHS

Member
Re: This file does not have a rogram

richc46: I did the uninstal and then used your link to get to the Windows Live Mail site. I downloaded it and opened my email but again I could not open any links and I get the same old message. "This file has no program...etc. Thanks anyway, GordonHS
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

richc46

Vista Guru
Gold Member
Re: This file does not have a rogram

I thought that my suggestion would be a quick fix, but guess not, try this.

Here is our great tutorial, written by our Administrator, which you said that you have

already read.

http://www.vistax64.com/tutorials/69758-default-programs.html

Usually, if you right click on the link go to properties, you can see what extension to use.

I hope that this will help solve your problem.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

richc46

Vista Guru
Gold Member
TY so much for your rep and kind words. As always, I and the rest of the Vista Forum

membership will do everything that we can to help you.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

GordonHS

Member
richc46: 1. When I right click on a link in my email I do not find a drop down which includes Properties so I can't identify the file for which I should create an association.
2. Iclicked on the Default Programs link you provided and I chose exe as the file to restore (I read that one of the Vista fixes is for a damaged association in the Registry). I downloaded the file and when I tried to open it my compter went into convulsions flashing the Chrome internet screen. I was able to shut down by quickly selecting Start, shut down. I had tried this once before with the same results. It looks like that avenue is not available to me. Do you know of a reason for the strange behaviour of my computer. Thanks, Gordon
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

Capt.Jack Sparrow

The Black Pearl
Vista Guru
You could try something that might work ..

Start > Type regedit and click ok.

Make a backup of Registry
File > Export > Registrybackup then save it

Go to:

HKEY_CURRENT_USER\Software\Classes\eml_auto_file\shell\open\command

Double click on Default in right pane and change Value Data for exactly that:

"C:\Program Files\Windows Mail\winmail.exe" /eml:%1

Then click on then try and see whether it works

Hope this helps,
Captain
 

My Computer

GordonHS

Member
Captain Sparrow. I can click on the email and it will open. When I click on a link (I don't know what file type it is; a right click does not show properties) I get the message " This file.. Thanks for your reply.
I wll print out your instructions for the registry. I have backed up the regitry. Hope to try this tomorrow. Thanks, Gordon
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

GordonHS

Member
Captain Sparrow: I very carefully followed the instructions you gave me and entered the value data (It didn't have a value previously). When I went back to my email inoox and clicked on a news message from Hewellett Packard and click on one of the products shown I stell get the message " This file....
Thanks for your help. Is there some other avenue to pursue? Gordon
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

Capt.Jack Sparrow

The Black Pearl
Vista Guru
Also ,

1, Make sure IE is the default browser to make that Open your IE

Goto Tools > Internet Options > Programs > Click on Make Default
Also Goto Control Panel > Programs > Default Programs > Set Associations
make sure for HTTP and HTTPS Internet Explorer is selected if not click on Change Program and Select it. If this didn't work.

Also if you have Google Chrome installed try to uninstall it.

2, Lets reset the IE to default settings

This will lose what ever you have customized setting you have in your IE.

GoTo Tools > Internet Options > Advance > Click on Reset see whether these fix your problem. Still if you have the same problem post us back

Hope this helps,
Captain
 

My Computer

GordonHS

Member
Captain Sparrow: Thank you for the information.
1. In tools, internet options,programs Internet Explorer is shown but the Make Default button is greyed out. Below is a box with a check mark. Notify....
2. In the set assosciations for HTTP and HTTPS the current default is Unknown Application. Change program brings up a blank window labelled Choose program....
There is no option to type anything. The only option is to cancel out of the window.
3. I have Google Earth and Google Updater in my Programs. The Google browser was uninstalled when my ISP technicl help spent two hours trying unsuccessfully to solve my problem. I much appreciate your suggestions and would appreciate any further insight into my problem. Gordon
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

GordonHS

Member
I tried Mozilla some years ago and it gave me problems and I never touched it again. If I install it and it corrects the Change program issue in set associations will it then take over as my browser? Thanks Gordon
 

My Computer

System One

  • Manufacturer/Model
    ASUS P5VD2-VM (PCI EX 16, 6 Usb, Core 2 support) 2.20 Ghz
    CPU
    Intel Core 2 DUO 2200 Processor 1 m cache
    Memory
    DDR 11 Kingston 667, 2 Gig
    Graphics Card(s)
    Intel 950
    Sound Card
    High Definition Audio Device
    Monitor(s) Displays
    ACER 22 inch Wide LCD Flat Panel
    Screen Resolution
    700:1
    Hard Drives
    250 Gig Western Digital SATA 11
    Case
    ATX IN WIN tower Case
    Cooling
    400 watt Dual Fan power supply
    Mouse
    Logitech Optical Mouse (wireless)
    Keyboard
    Logitech Multimedia Keyboard (wireless)
    Other Info
    Motorola Cable Modem
    D-Link Router DI 604
    Toshiba Satellite A10 laptop on network

Capt.Jack Sparrow

The Black Pearl
Vista Guru
I tried Mozilla some years ago and it gave me problems and I never touched it again. If I install it and it corrects the Change program issue in set associations will it then take over as my browser? Thanks Gordon
Yup .. i assume it should take care of this issue.

Hope this helps,
Captain
 

My Computer

richc46

Vista Guru
Gold Member
I did not forget about you, just not much to say. I had a situation, just today. It had to do with programs that would not open. It sounded very similar to your situation, except this is mail related. The remedy, if it works is easy. Give this a try.

Save time the solution is at the end, pane 27.

http://www.vistax64.com/general-discussion/268369-boot-scan-fail.html

There were enough similarities that I thought about you, but different enough that I have my doubts.

I was not sure if the Capt solved the problem.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT
Top