ZIP File Support - Restore

ByLine
How to Restore the Built-in ZIP File Support in Vista
Synopsis
This will show you how to restore the built-in support of ZIP files in Vista by restoring the ZIP file association.
How to Restore the Built-in ZIP File Support in Vista

information   Information
This will show you how to restore the built-in ZIP file support in Vista by restoring the ZIP file association.
Note   Note
You may have used a program like WinZip, WinRar, or some other Zip program and Vista will now not go back to it's default Zip handler in explorer after you uninstalled the other program.
Tip   Tip
If when you try to open a ZIP folder and it does not open in a Windows Explorer window, then turn on Compressed Folders. See related link below for how.
warning   Warning
This must be done while logged on to a administrator account.


Here's How:
1. Click on the download button below and save the zipfix_vista.reg file to your desktop.​
NOTE: This also contains the reg file to turn on Compressed Folders.​
download

2. Right click on the downloaded zipfix_vista.reg file and click on Merge.​
3. Click on the Run button in the Security Warning pop-up. (See screenshot below)​
Security warning.jpg

4. Click on Continue (UAC), Yes, and then OK when prompted.​
5. When done, you can delete the downloaded zipfix_vista.reg file if you like.​
6. Restart the computer to apply changes.​
That's it,
Shawn


 
Last edited:
Shawn Brink

Comments

Yes, I can now open my zip folder! But now I can't figure out how to change the icon back to the folder with the little zipper on top. I'm running out of places to look in my Control Panel.
 
Well, hey, what do you know! It worked! Thanks so much for your advice and patience with my ignorance. :) :zip: This guys lips are zipped. I thought it was appropriate... :)
 
Re: ZIP file in Vista

omg! it works. thanks alot!!! i looked everywhere and this was the only place that had the solution.
:D Nice to have you sorted it out Mis and I don't have any problem too with my ZIP since I got two application for ZIP File such IZarc and WINZip and can you explain to me Doctor Brink does it really important to make Vista back to its original ZIP or doesn't really need it ? :D
 
Hello Jeffrey,

It just depends on your prefrences and which one you want to use. WinZip or the ZIP feature in Vista.
 
Hello I am having a problem with my compressed folder. I have ran step 1 and two however one one profile this step did not fix the problem it still tries to open with IE. I have rebooted and everthing. Also on the profile that it did fix it opens up in a embroidery software program I downloaded. How do I change it back to open up in the regular progam. I am afraid that I will mess something up again. I don't know what program to select to open up my pes files. Thank you.
 
Hello RW, and welcome to Vista Forums.

Parts of the REG file will only affect the user account that is currently logged on and merged in. Log on to that user profile, and merge the REG file in it as well to see if it may help afterwards.

Hope this helps,
Shawn
 
Strange. Did you restart the computer after applying the REG file?

If so, you might consider using the free program 7-Zip for ZIP files. It's a great little program.
 
Shawn,
Awesome! Problem solved. My computer stopped opening zip files all of a sudden yesterday. Followed other threads, other users had success finding explorer.exe to open zips with......I couldnt locate the explorer at all on my computer. Found this forum, downloaded zipfix_vista like you recommended, and worked. Thanks alot. Im now a new member of this forum, and will keep link in favorites as a first go to if future problems arise.

-Ethan:D
 
Hello Jovanny, and welcome to Vista Forums.

You can download and merge the REG file in the tutorial on the first page of this thread to restore the default association of ZIP files. :)
 
Hi there,

sorry to add to this list of problems! hope someone can help me please?

My system just stopped giving me "extract..." when drag and right-click a .zip file.

Extract All is working, and zip and unzip functions and association is fine. It is only the drag with right button no longer shows "extract.." I only have Copy, Move, Create shortcut.
I used to have extract... as well.

Any ideas?

PS i have run the reg repairs on the file assocation just in case.

Thanks!

Gus
 
Top