• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

What browser do you use?

What internet browser do you use?

  • Firefox 2

    Votes: 20 4.1%
  • Firefox 3

    Votes: 288 59.5%
  • IE6

    Votes: 5 1.0%
  • IE7/IE7 Pro

    Votes: 102 21.1%
  • IE8

    Votes: 75 15.5%
  • Opera

    Votes: 57 11.8%
  • Chrome

    Votes: 31 6.4%
  • Maxthon

    Votes: 8 1.7%
  • Other

    Votes: 59 12.2%
  • Browser...we don't need no stinking browser

    Votes: 7 1.4%

  • Total voters
    484

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
US of A

Posts
2,308
You should have SP2, if you want switch off the Windows Search in services, I do as I find in is not needed, search still works just a little slower, you barely notice.
Agreed. Sp2 is important and search indexer can be disabled although if you do Windows will nag you that your searches can be faster.

On topic I prefer FF but I have opera installed as a secondary browser. I don't use safari that much. I have srware iron installed but I never liked the chrome interface so I never use it.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB

Cammygirl192

Cammy White FTW
Member
England

Posts
110
Opera is just a Chromium clone since few years, unfortunately, if they hadn't given up with their Presto engine I'd probably still be using it.
Dunno why they can't just open source their old browser for people to do stuff with and improve the layout engine, they still update it for Opera Mini, I think...
 

My Computer

System One

  • Manufacturer/Model
    Packard Bell imedia s3210
    CPU
    AMD Athlon(tm) 7450 Dual Core Processor (2.40GHz)
    Memory
    2.00GB
    Graphics Card(s)
    NVIDIA GeForce 8200

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
US of A

Posts
2,308
Thanks for that. I was going to install the latest version but instead I installed version 12.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB

Cammygirl192

Cammy White FTW
Member
England

Posts
110
Thanks for that. I was going to install the latest version but instead I installed version 12.
It's the only browser I have used that doesn't crash on Twitter much, actually.
I'd love to leak the source code of Presto, and write a layout engine based on it.
 

My Computer

System One

  • Manufacturer/Model
    Packard Bell imedia s3210
    CPU
    AMD Athlon(tm) 7450 Dual Core Processor (2.40GHz)
    Memory
    2.00GB
    Graphics Card(s)
    NVIDIA GeForce 8200

ilikefree

Vista Guru
Gold Member
New Zealand

Posts
2,892
I just looked through this thread and in 2011 I was using Firefox and liking it but since then they have made some changes that I didn't like so I switched to Pale Moon
I find Pale Moon to be like Firefox was when users had a say in how it looked (ex. tabs on bottom, etc.)
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

Cammygirl192

Cammy White FTW
Member
England

Posts
110
kill that Google Chrome copycat ASAP with... fire

As I've said before I love Opera 12.17, in the old times did anyone remember anyone using Opera? No one I know has heard of it.
(also the only reason Chrome dominated the web nowadays, is because half the time stats for Opera are being counted as Chrome)
 

My Computer

System One

  • Manufacturer/Model
    Packard Bell imedia s3210
    CPU
    AMD Athlon(tm) 7450 Dual Core Processor (2.40GHz)
    Memory
    2.00GB
    Graphics Card(s)
    NVIDIA GeForce 8200

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
US of A

Posts
2,308
kill that Google Chrome copycat ASAP with... fire

As I've said before I love Opera 12.17, in the old times did anyone remember anyone using Opera? No one I know has heard of it.
(also the only reason Chrome dominated the web nowadays, is because half the time stats for Opera are being counted as Chrome)
Opera shows up seperate from Chrome. https://en.wikipedia.org/wiki/Browser_usage
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB

ilikefree

Vista Guru
Gold Member
New Zealand

Posts
2,892

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed
I have been using Opera for 12-18 mths on my desk top with no problems, it was fast, well laid out and suited me just fine, but about 2-3 weeks ago it just would not d/l video as it did before it had become hit and miss, I did windows restore to max past date but not any better so I did a Dell restore again no improvement.
I have in the past tried Firefox on two occasions but did not like it but decided to try it again alas no better and again cannot get it to down load video but that is probably my fault being new to it.
I have been warned against Chrome and am unsure if Edge would be compatible with Vista 32. Is Opera having problems ? How about Safari or any other suggestions for a browser.
 

My Computer

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
US of A

Posts
2,308
There may be bugs in the current version. If you recently updated try reinstalling the last version that you had installed when it last worked correctly. I'm not sure how to tell you to backup your profile though. As for using edge as far as I know that it is only for 10 and safari is only for mac so neither are options for you on Vista. I suppose that we are opposite. i really only prefer Firefox. I have opera installed as a secondary browser but I refuse to install any version past 12 because any later version is based in chrome which I despise. If you recently updated flash (which is likely what the videos are using) you might want to revert to an older version since that could also be a cause.

Are you experiencing this issue on only one website? If so it might have recently changed so now it is also possible that the website dropped support for Opera since it isn't widely used or haven't completely implemented such changes to make opera compatible, speaking hypothetically of course.

You could also try chrome. There are also other browsers to try but I can't speak to them.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB

Vistaar

Vista Guru
Posts
539
Chrome ended support for Vista in April: https://chrome.googleblog.com/2015/11/updates-to-chrome-platform-support.html.

The Chromium Project has been working since January to remove support for Vista and XP: https://bugs.chromium.org/p/chromium/issues/detail?id=579196. That means that no Chromium-based browser (including Opera) can really support Vista much longer. Of course IE 9 will be supported until April 11, 2017, when Microsoft ends support for Vista SP2. Frankly, if you really dislike Firefox, then you should probably be thinking in terms of a new operating system.
 

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT
Thanks townsbg and Vistaar, loss of d/l was on any site and now that I think of it I think my problems are linked to 'Chrome' as an old app that I use for a sig on one forum shows that I am using Chrome as a browser?? I thought this was a mistake as I was using Opera so what you say makes sense. I have installed Firefox once more as I have very limited options and guess I will just have to get to grips with it, at least I know where to come for help.
 

My Computer

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
US of A

Posts
2,308
Yes Firefox based browsers are just about the only "modern" browsers that still support Vista. I say modern because IE9 isn't. FF still supports XP and I haven't heard anything about Mozilla stopping support for either OS. Now if you don't particularly like firefox then you can try one of the derivatives based on it. You can also try skins.
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB
I am gradually getting used to Firefox, I have to log onto web sites each time I visit despite ticking 'remember me' box but Firefox does at least remembers user name and p/w, 2-4 days ago I had the following pop up which was a worry as I did not know updates were even being checked and as far as I know my version was up to date 43.0.1exe file version 4.42.0.0 so off I went to the d/l site where I down loaded and installed the recommended version which turned out to be exactly the same??? today I have the same pop up which I will ignore, what is going on?

Firefox pop up.JPG
 

My Computer

Vistaar

Vista Guru
Posts
539

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
US of A

Posts
2,308
Thanks townsbg and Vistaar, loss of d/l was on any site and now that I think of it I think my problems are linked to 'Chrome' as an old app that I use for a sig on one forum shows that I am using Chrome as a browser?? I thought this was a mistake as I was using Opera so what you say makes sense. I have installed Firefox once more as I have very limited options and guess I will just have to get to grips with it, at least I know where to come for help.
Some Chrome based derivatives such as Chromium and SRWare Iron still support XP and higher. SRWare Iron advertises itself as a version that has removed all tracking information. SRWare Iron - The Browser of the Future
 

My Computers

System One System Two

  • Operating System
    Windows 7 Pro x64
    Manufacturer/Model
    Mid 2010 iMac
    CPU
    Quad core 3.2 Ghz Intel I3
    Memory
    8 gb
    Graphics Card(s)
    ATI Radeon HD 5670 512 mb ram
    Screen Resolution
    1920x1080 and 1440x900
    Hard Drives
    1 TB
  • Operating System
    Windows 2008 R2 Enterprise
    Manufacturer/Model
    Compaq Presario SR5350F
    CPU
    Pentium 2.0 gHZ Dual core E2160
    Memory
    2 gb
    Screen Resolution
    1440 x 900
    Hard Drives
    300 GB
Posts
98
I've been using FireFox for quite a long time.

I also have Pale Moon 64-Bit version installed, that's used once in a while. Very similar to Firefox and able to use many of Firefox's add-ons.

https://www.palemoon.org/

I also installed Iron which appears to be a working alternative to Chrome. One problem I have with Chrome is it runs background google update processes that eventually cause problems. This is one of the reasons why I removed Chrome from my computer.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    Thinkcentre
    CPU
    Intel Core 2 CPU 2.67 Ghz
    Motherboard
    OEM
    Memory
    4 GB
    Monitor(s) Displays
    NEC
    Screen Resolution
    1920 x 1080p
Posts
78
I was forced to upgrade to Windows 7, so I'm on Google Chrome. But while using Vista on my laptop, and secondary PC, I still use Google Chrome. It has always worked the best for me.

Regards,
Josh
 

My Computer

System One

  • Operating System
    Windows Vista Business x64
    Manufacturer/Model
    Custom Built
    CPU
    Intel Core i5-3570 @ 3.4GHz
    Motherboard
    Asus P8P67 Pro
    Memory
    12GB DDR3-1600
    Graphics Card(s)
    MSI NVIDIA GeForce GTX960 GAMING X 4GB
    Sound Card
    Realtek HD Audio (Built in)
    Monitor(s) Displays
    Dell E2210H, Dell E2010HC, ViewSonic VA1917A
    Screen Resolution
    1920x1080, 1600x900, 1366x768
    Hard Drives
    256GB Samsung 850Evo SSD
    1TB Toshiba 7200RPM HDD
    500GB Toshiba 7200RPM HDD
    PSU
    Corsair CX750
    Case
    Antec Solution SLK1650
    Cooling
    Cooler Master Hyper 212EVO
    Mouse
    Logitech M500
    Keyboard
    Dell Quietkey
    Internet Speed
    Fast!
    Other Info
    This is my main PC. It is custom built by me.

Vistaar

Vista Guru
Posts
539
while using Vista on my laptop, and secondary PC, I still use Google Chrome.
Too bad Chrome ended support for Vista and XP in April 2016 (final update 49.0.2623.112). But if you know how to update Flash short of updating Chrome itself, there might be some Chrome diehards who need that information.
 

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT